summaryrefslogtreecommitdiff
path: root/app-text/cmark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/cmark
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest5
-rw-r--r--app-text/cmark/cmark-0.28.0.ebuild33
-rw-r--r--app-text/cmark/cmark-0.28.3.ebuild33
-rw-r--r--app-text/cmark/metadata.xml18
4 files changed, 89 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
new file mode 100644
index 000000000000..8d2dd0054ffe
--- /dev/null
+++ b/app-text/cmark/Manifest
@@ -0,0 +1,5 @@
+DIST cmark-0.28.0.tar.gz 228973 BLAKE2B e0f42a7a5929eb8fb7a2fb9405372d626b2fea5f895b9320a28629022a8280d01af67e8e13101565ce86a2dbc4b8191eb461e70e45e7fa33c72b8e8266c2ee78 SHA512 86aeb42f17440c8e743057851bc3cee9ed4b3fa27dacc37d6af54dee7739210a712020e59c102ed1852b7c3f904881cb4e9b80ea475772095514c4025284cbb6
+DIST cmark-0.28.3.tar.gz 229391 BLAKE2B b235d3dd8ed9b83d8fd6ec495d311bed854ad61d28e5a5087f40f7e512977892fcdff7c51e8683db87e0ee8e5e73338fe11b8829e70c6f07c59e917a8b7268cc SHA512 409105a3228a8ae22ba6acf95cd99bc9a2c20f8603aa0e803a33172eb6ef53f80f8f0262d2258b77f9fd6e1f2e9017a6c906b88f761e053c09ef88c9ffab7d29
+EBUILD cmark-0.28.0.ebuild 704 BLAKE2B 9c0ebfc47577cfef39d9333594d0a200d96ea64f57698cced39e681c3576790edcde14329e1ae8d03e9df38f05c2cce88c33d84691860482b073127f1536589e SHA512 c279cc5b8d899436fed2eed3d4979ac462b28f2248e2fbab934d8ce4075447c11525deb6bcd7fdc7544c36abf71b113ab6266f59f8a1f626c9b84b0fc38e0764
+EBUILD cmark-0.28.3.ebuild 718 BLAKE2B 977b531e4fab755bb761741e14355cbcf0d00d8598373fe58cc6612ea2ca6fb434dbb54e46b042793cad429b10346430c6cd8b96d68d538d2c42b91f097ddb7c SHA512 ea9c2dade4874fbe7b0793320b6663955ad517891a627f92007164a3bfd4f86bdb15711e7b6b41273d25740e6d98738e22ecfc01891d4eb4032a8e412a742302
+MISC metadata.xml 577 BLAKE2B f99edfb972715ce4b1660a5e68c0261c9b8d8f2914f5bd804227bbddeae1528205bbed55c20d6d366ecfdd6a01a69bb31decd57ed40f0440de4946e86339e659 SHA512 93ccb3c6ec9907489589f3aae77d00eb2858d5d436b78be1f711a060f47fadf92d2da8a81a9388ae7946ad1b6a93cc88cb96bfe15cdd81b1e56bdd7f4750a4c1
diff --git a/app-text/cmark/cmark-0.28.0.ebuild b/app-text/cmark/cmark-0.28.0.ebuild
new file mode 100644
index 000000000000..8645624e81eb
--- /dev/null
+++ b/app-text/cmark/cmark-0.28.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-text/cmark/cmark-0.28.3.ebuild b/app-text/cmark/cmark-0.28.3.ebuild
new file mode 100644
index 000000000000..706c679b378c
--- /dev/null
+++ b/app-text/cmark/cmark-0.28.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-text/cmark/metadata.xml b/app-text/cmark/metadata.xml
new file mode 100644
index 000000000000..da44e88f8f6e
--- /dev/null
+++ b/app-text/cmark/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ CommonMark parsing and rendering library and program in C.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">commonmark/cmark</remote-id>
+ </upstream>
+</pkgmetadata>