summaryrefslogtreecommitdiff
path: root/app-text/chm2pdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/chm2pdf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/chm2pdf')
-rw-r--r--app-text/chm2pdf/Manifest4
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild39
-rw-r--r--app-text/chm2pdf/files/tempdir.patch71
-rw-r--r--app-text/chm2pdf/metadata.xml11
4 files changed, 125 insertions, 0 deletions
diff --git a/app-text/chm2pdf/Manifest b/app-text/chm2pdf/Manifest
new file mode 100644
index 000000000000..8de80a4acc34
--- /dev/null
+++ b/app-text/chm2pdf/Manifest
@@ -0,0 +1,4 @@
+AUX tempdir.patch 3694 BLAKE2B a88d3709ee23f43ab6a9a9b3ec83306d964d3d791b4552f99df26bdf09924cc40b721b0f24c8807b47f0e91b3eb8d46dae1c15ee53b9fe7974431c523bda5b50 SHA512 e7d29e71afad11c79d508c35c9060a39308c78e654f00808cb38b7e75ebf5f885bbd436f58e9900977c2e81d0f4a7f543daeab6bd2f9a919c4c3b74dba33c325
+DIST chm2pdf-0.9.1.tar.gz 19955 BLAKE2B 6f16f35d25904cf1b42e91c46f58b279fceb11a328a88e14f20a9749148a4a5932af4884a19f57dc89b0135b3b8acd2dc880265aa46dfb9887ab6212a59172bd SHA512 1d1997b17750f371e60cc6bf9693a8e4316deadd63247700f6ebd1bf02340f2e0524766a6be846d0f6349416b8551609da63fbf60ecd62766cf0d9b4f0c886d3
+EBUILD chm2pdf-0.9.1-r2.ebuild 768 BLAKE2B 3dee8875ae605f35e8e3cbc992d74ae0a3188a9801183775a7a15eff4f64009a44235e9498be0e68fb8065cd1a6391adb4ab8e16b79ee0473ca637cd2c7c8397 SHA512 e6015c7b5eed96714e2afac98132141f55067654cd65dfb510c4266a68fc69328fbaa28bc771cc8978ec45f512f50e3d4234e7be1c9f09932daec093ef35a7cf
+MISC metadata.xml 327 BLAKE2B 8fdf9fef07cf22c5abbe925f527c9978e877e0cb28f84fc80845f84b24a2f0a77b20967e582cf381149adfb36d870bcd5826bfa83c9a4f0c6317248a47a92dc5 SHA512 3d6d3798e07d0d313b4411c19c9183019924c080d8deb9aa52c6d882db3d8ccff0a2cf69d5e022fb2643a8eeb5ef8ab6d7f166afb440e7c70e5ac372c968b885
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..d4ace08fe54d
--- /dev/null
+++ b/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A script that converts a CHM file into a single PDF file"
+HOMEPAGE="https://code.google.com/p/chm2pdf/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pychm[${PYTHON_USEDEP}]
+ app-text/htmldoc
+ >=dev-libs/chmlib-0.40-r1[examples]
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+PATCHES=( "${FILESDIR}/tempdir.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare(){
+ python_fix_shebang .
+}
+
+src_install() {
+ default
+ python_doscript ${PN} || die "failed to create executable"
+}
diff --git a/app-text/chm2pdf/files/tempdir.patch b/app-text/chm2pdf/files/tempdir.patch
new file mode 100644
index 000000000000..6bb5fe55d00d
--- /dev/null
+++ b/app-text/chm2pdf/files/tempdir.patch
@@ -0,0 +1,71 @@
+--- chm2pdf-0.9.1.orig/chm2pdf 2008-07-09 12:42:26.000000000 +0200
++++ chm2pdf-0.9.1/chm2pdf 2009-02-25 20:58:53.000000000 +0100
+@@ -27,6 +27,8 @@
+ import os, os.path
+ import re, glob
+ import getopt
++import tempfile
++import shutil
+ # from BeautifulSoup import BeautifulSoup
+
+ global version
+@@ -39,8 +41,8 @@
+ global filename #the input filename
+
+ version = '0.9.1'
+-CHM2PDF_TEMP_WORK_DIR='/tmp/chm2pdf/work'
+-CHM2PDF_TEMP_ORIG_DIR='/tmp/chm2pdf/orig'
++CHM2PDF_TEMP_WORK_DIR=tempfile.mkdtemp()
++CHM2PDF_TEMP_ORIG_DIR=tempfile.mkdtemp()
+
+
+
+@@ -299,16 +301,6 @@
+ # ########################### File extraction and correction: START ############################
+ #
+ if options['dontextract'] == '':
+-
+- try:
+- os.mkdir(CHM2PDF_TEMP_WORK_DIR)
+- except OSError: # The directory already exists.
+- pass
+-
+- try:
+- os.mkdir(CHM2PDF_TEMP_ORIG_DIR)
+- except OSError: # The directory already exists.
+- pass
+
+ try:
+ os.mkdir(CHM2PDF_ORIG_DIR)
+@@ -620,7 +612,7 @@
+ print '\t--continuous\n\t\tSpecifies that the HTML sources are unstructured (plain web pages).\n\t\tNo page breaks are inserted between each file or URL in the output.'
+ print '\t--cookies \'name="value with space"; name=value\'\n\t\t'
+ print '\t--datadir directory\n\t\tSpecifies the location of the HTMLDOC data files, usually /usr/share/htmldoc or C:\Program Files\HTMLDOC '
+- print "\t--dontextract \n\t\tIf given, %s will not extract the HTML files from the given CHM file, but will use previously extracted copies from the temporary directory " %name + '(i.e. ' + CHM2PDF_TEMP_ORIG_DIR + ' and ' + CHM2PDF_TEMP_WORK_DIR + '). Usually you will use this option after you have used the \'--extract-only\' option to extract the files in order to correct them manually (in ' + CHM2PDF_TEMP_WORK_DIR + '). After the correction, a call with \'--dontextract\' will not overwrite your changes, but will use the corrected files instead.'
++# print "\t--dontextract \n\t\tIf given, %s will not extract the HTML files from the given CHM file, but will use previously extracted copies from the temporary directory " %name + '(i.e. ' + CHM2PDF_TEMP_ORIG_DIR + ' and ' + CHM2PDF_TEMP_WORK_DIR + '). Usually you will use this option after you have used the \'--extract-only\' option to extract the files in order to correct them manually (in ' + CHM2PDF_TEMP_WORK_DIR + '). After the correction, a call with \'--dontextract\' will not overwrite your changes, but will use the corrected files instead.'
+ print '\t--duplex\n\t\tSpecifies that the output should be formatted for double-sided printing.'
+ print '\t--effectduration {0.1..10.0}\n\t\tSpecifies the duration in seconds of PDF page transition effects.'
+ print '\t--embedfonts\n\t\tSpecifies that fonts should be embedded in PDF output.'
+@@ -1084,13 +1076,6 @@
+ print 'CHM file "' + filename + '" not found!'
+ return
+
+- #remove temporary files
+- if options['dontextract'] == '':
+- if options['verbose']=='--verbose' and options['verbositylevel']=='high':
+- print 'Removing any previous temporary files...'
+- os.system('rm -r '+CHM2PDF_ORIG_DIR+'/*')
+- os.system('rm -r '+CHM2PDF_WORK_DIR+'/*')
+-
+ cfile = chm.CHMFile()
+ cfile.LoadCHM(filename)
+
+@@ -1105,6 +1090,8 @@
+ os.system('extract_chmLib ' + filename + ' ' + CHM2PDF_ORIG_DIR + '&> /dev/null')
+
+ convert_to_pdf(cfile, filename, outputfilename, options)
++ shutil.rmtree(CHM2PDF_TEMP_WORK_DIR)
++ shutil.rmtree(CHM2PDF_TEMP_ORIG_DIR)
+
+
+ if __name__ == '__main__':
diff --git a/app-text/chm2pdf/metadata.xml b/app-text/chm2pdf/metadata.xml
new file mode 100644
index 000000000000..0d5011fb8a78
--- /dev/null
+++ b/app-text/chm2pdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">chm2pdf</remote-id>
+ </upstream>
+</pkgmetadata>