summaryrefslogtreecommitdiff
path: root/app-text/capyt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-text/capyt
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-text/capyt')
-rw-r--r--app-text/capyt/Manifest4
-rw-r--r--app-text/capyt/capyt-1.0.ebuild28
-rw-r--r--app-text/capyt/capyt-1.1.1.ebuild27
3 files changed, 29 insertions, 30 deletions
diff --git a/app-text/capyt/Manifest b/app-text/capyt/Manifest
index 71e233dffb77..f335556d64f5 100644
--- a/app-text/capyt/Manifest
+++ b/app-text/capyt/Manifest
@@ -1,3 +1,3 @@
-DIST capyt-1.0.tar.gz 2152 BLAKE2B bde81e802c310a95c37695943d35a6cc98557f92199b7f8d5983340d1cbd6d2ffe4c07b48a9ea724603766d371cd80519c01c663fb8303c1abec3879e12caf34 SHA512 325de4bdc3d6b7e6d0926f37cb7facfbc216c0d46280576a3424add0b8c081405809a23982cda3032b3443a41ddbd7f6997040f7353defcbe72895b1ceff8384
-EBUILD capyt-1.0.ebuild 563 BLAKE2B ffc4b2f372ae2cf90bf6239b0d19fe8828b6230e28faf639845fcd0cd44f08854aa48d8b2269b303abc5067b1a87a824f958f6e13ba3d4a714a74b2a64563100 SHA512 c6a28572d692f057816336fe4028f99982750592e2ff751481c5cf436f22a0f89c2fc6d80e8ea8d431e4096bdc12232787454d3bbf32a5ebf122f524c37ce4fd
+DIST capyt-1.1.1.tar.gz 3247 BLAKE2B 259c1cc7eddc88853518ed106f25e9b1d47a5c4604e749d25fb2133f11d90e78672473a9dd31fa80322b4c5177163fe5a177d27a6fd9a7cd31ef12db7ee3ed0f SHA512 863164967aab93088d39b0324d1324145f41ba76b9d21874ea6a3aa49955e1ec3430c7bcc9eb100c51b9e159c63758b6474d3bad586383d7c10d9f1118340123
+EBUILD capyt-1.1.1.ebuild 621 BLAKE2B 1a515438c4edffcfe46c918a72269eee288be9a2b79462407f167006623d88a0e85b35a5a27faf78c85aa9dbf7d90eb39268f11a0d73f6849668743cf877315c SHA512 8a140ac9876c903b14f0d6649f5f520abed1fcdae3816c75b7c0980c3770f1046d6b623d0575a267fc9b39dc7608b5b9441fa84b89cbec70cb40b42b46d59952
MISC metadata.xml 344 BLAKE2B 2b09c758b212196592a83ba9e2f30591f97d222619bf3a494fcc025789c46d70f55b955400c580dbc9d3f5ea3cdb3662d79e2960d88e8b7e089a741c7fa6041d SHA512 f9e35a54a3d719a4114e2bc758096c1f6365838163ab5f6a3353bd318581683ca4757be60d0dbb8457099c1e174518078091a94e2f23f086903f45be94c4915d
diff --git a/app-text/capyt/capyt-1.0.ebuild b/app-text/capyt/capyt-1.0.ebuild
deleted file mode 100644
index 13690113dc90..000000000000
--- a/app-text/capyt/capyt-1.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5..6} )
-
-inherit python-single-r1
-
-DESCRIPTION="A python3 CLI utility to interface with cpy.pt paste service"
-HOMEPAGE="https://github.com/lbatalha/capyt"
-SRC_URI="https://github.com/lbatalha/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/requests[${PYTHON_USEDEP}]
-"
-
-src_install() {
- dodoc README.md
-
- python_doscript capyt.py
-}
diff --git a/app-text/capyt/capyt-1.1.1.ebuild b/app-text/capyt/capyt-1.1.1.ebuild
new file mode 100644
index 000000000000..3ecc5167169f
--- /dev/null
+++ b/app-text/capyt/capyt-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="A python3 CLI utility to interface with cpy.pt paste service"
+HOMEPAGE="https://github.com/lbatalha/capyt
+ https://pypi.org/project/capyt/"
+SRC_URI="https://github.com/lbatalha/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"