summaryrefslogtreecommitdiff
path: root/app-text/blogc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/blogc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/blogc')
-rw-r--r--app-text/blogc/Manifest4
-rw-r--r--app-text/blogc/blogc-0.13.9.ebuild59
-rw-r--r--app-text/blogc/blogc-9999.ebuild59
-rw-r--r--app-text/blogc/metadata.xml24
4 files changed, 146 insertions, 0 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
new file mode 100644
index 000000000000..a0b373948ee1
--- /dev/null
+++ b/app-text/blogc/Manifest
@@ -0,0 +1,4 @@
+DIST blogc-0.13.9.tar.xz 319084 BLAKE2B 2e23e85d657e2905a94f71cebae31868a241783d44dc4da76c3bda02cf7c96c0516a834399e0b5bb66716c959acc32dac9d1374388a4e597a03dff9e8e11fef3 SHA512 9160884fd0a4088abacb9f4f3168c80a5a8b01d81a13606f3abf8c0f54b2bf0459f1c3833ab953a072eb87b8b8d8fc31467036999e85e2448fecbc36f97bb1db
+EBUILD blogc-0.13.9.ebuild 1120 BLAKE2B 4d5a2dba5c10f3bd5015842da3f9a24b41ffa71343f783371a9c50aa0c32bc5e96b0becb56364c09d163d0e64246688d45676fb333de9ab8718c5fe8869bb001 SHA512 80e734b9155ac024c78b58e68216d7f591507ca5aa2cd264e69f0b2a71837943c3ec6b7acd00e5d5b4b08a6c64bc370bf926730a8b8ed7ffe8d1ce3ab0865e36
+EBUILD blogc-9999.ebuild 1120 BLAKE2B 234392dc7c1e42c3bcd2c3ac4b1a648ee9e4fa6fc486cfcc60ef0af1c0cfb97ea68bc2b2ce3da820bdd88f05ef5993b7dc6589e52137d8d1e7cbce19d9c0a064 SHA512 ed4c808f2cfa1435972a53ae17f76a9e3423943713759cb7ad7378e6417a3912dbb16e0964d963dac8a476be37c90a42d8f875128101ee806f12a8ab11a519d9
+MISC metadata.xml 785 BLAKE2B 90817e117dbf1f0e60d655206ad0cc3f3cecf2b97a16ba43fdf84ae0f621ee6296af2ab6a17bb205d82b1d107be3f62b75d9c740aeab0267b02947a4bcc50aea SHA512 31230bdb8113bb73662328e0e657e710cd33e65f126d638f0cefdacbe97525643604f48ce3da27f80b8163d129092c7df7eee265cd6d6194cd0181b138230206
diff --git a/app-text/blogc/blogc-0.13.9.ebuild b/app-text/blogc/blogc-0.13.9.ebuild
new file mode 100644
index 000000000000..29595c41810e
--- /dev/null
+++ b/app-text/blogc/blogc-0.13.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd make test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable make make) \
+ $(use_enable httpd runserver) \
+ --disable-make-embedded \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
new file mode 100644
index 000000000000..eab99becb995
--- /dev/null
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd make test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable make make) \
+ $(use_enable httpd runserver) \
+ --disable-make-embedded \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/metadata.xml b/app-text/blogc/metadata.xml
new file mode 100644
index 000000000000..6a921452e508
--- /dev/null
+++ b/app-text/blogc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ blogc(1) is a blog compiler. It converts source files and templates
+ into blog/website resources.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">blogc/blogc</remote-id>
+ </upstream>
+ <use>
+ <flag name="git">Build blogc-git-receiver tool</flag>
+ <flag name="make">Build blogc-make tool</flag>
+ <flag name="httpd">Build blogc-runserver tool</flag>
+ </use>
+</pkgmetadata>