summaryrefslogtreecommitdiff
path: root/app-text/blogc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/blogc
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/blogc')
-rw-r--r--app-text/blogc/Manifest5
-rw-r--r--app-text/blogc/blogc-0.12.0.ebuild57
-rw-r--r--app-text/blogc/blogc-9999.ebuild59
-rw-r--r--app-text/blogc/metadata.xml24
4 files changed, 145 insertions, 0 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
new file mode 100644
index 000000000000..76239e517868
--- /dev/null
+++ b/app-text/blogc/Manifest
@@ -0,0 +1,5 @@
+DIST blogc-0.12.0.tar.xz 290484 SHA256 85453c0184396f217ac95ae8ba70f0693b16f57321f82a09b7ff46d3a1d257ac SHA512 959610d6be23bbb011a881712deaa8100120a1a76c4cf4722716a915d55af7ca93ed416d3a39cb8fbad64e0693b64fbfe3055b1a7d012a003c05122a199a65b9 WHIRLPOOL 8ec096d2fbe537b29265dc92eea8b913e83396a6dc1629e9a86434e0e963ee4804183625c1a51b9730f7822175af77a0ad5297614518b86c25d22c9b54ef4300
+EBUILD blogc-0.12.0.ebuild 1059 SHA256 f2193f16013b89cd5a75ce5f889e49fe31d95a0dbc2677d90a28622aef4ffc72 SHA512 682eaabc08c412f8783fcf418d7c67cfca5c1a00967d57c6ad7bb45261d7460108ed8374cac9c7c7ed9f39529ef9e1056638fd24f14a4b20fbc94c127d103bf5 WHIRLPOOL 2dfcf4f1d00df9699915999bcef67a5a7ce2ed29a970a2bdab69b3b2dc8179accc02450582019092c7e85b58e9eaabc13bde5fbe5957a1396a5e47ce2bac86b2
+EBUILD blogc-9999.ebuild 1120 SHA256 3bcc8e0219dfab274b1d779146910a7addc0923d59bc7224669f531873acd5b2 SHA512 ed4c808f2cfa1435972a53ae17f76a9e3423943713759cb7ad7378e6417a3912dbb16e0964d963dac8a476be37c90a42d8f875128101ee806f12a8ab11a519d9 WHIRLPOOL c47edca97b898f9c2648a77c633de276943cfbcf1babcdbeb7df58ad655fb214755c8b027283d6a3467f8df63c079b0605e9fa8d42004467dcb8baff6ab125a4
+MISC ChangeLog 7443 SHA256 c97584592377bacef640f5acef20fe7db503e1d77eee817576d42e00b8ac9e6e SHA512 590323ef815f638baa4525d3ea45a1f3cc316ff820c266af4ce20cf1df741e7ac05d347fb7f4a598b38c90505717bbfb3bdbd2938fb9cd7310e4e6050fe3aa5b WHIRLPOOL bcb6fce5ce97bbb0d7ac1bec316568b36cc28076f5f1fe93a7ac47b72cea9ef1e20e86df61a6ac583e4ce35b0c9340d78bc39b06314d585ff9f6043ee0fba927
+MISC metadata.xml 785 SHA256 86755fe3de81a18ae42a2e43700cbee96209b3b1645bc31b31acfbdddbaa8343 SHA512 31230bdb8113bb73662328e0e657e710cd33e65f126d638f0cefdacbe97525643604f48ce3da27f80b8163d129092c7df7eee265cd6d6194cd0181b138230206 WHIRLPOOL 842602c93857ff4ca6724b868e007076abdf8ed47619cf6f90d70fedef798c55653970ad58a12423d2c835896c3b6c3a4168e614e499d68baf1797c49744c9d7
diff --git a/app-text/blogc/blogc-0.12.0.ebuild b/app-text/blogc/blogc-0.12.0.ebuild
new file mode 100644
index 000000000000..8dfe5bbee967
--- /dev/null
+++ b/app-text/blogc/blogc-0.12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable httpd runserver) \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
new file mode 100644
index 000000000000..eab99becb995
--- /dev/null
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd make test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable make make) \
+ $(use_enable httpd runserver) \
+ --disable-make-embedded \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/metadata.xml b/app-text/blogc/metadata.xml
new file mode 100644
index 000000000000..6a921452e508
--- /dev/null
+++ b/app-text/blogc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ blogc(1) is a blog compiler. It converts source files and templates
+ into blog/website resources.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">blogc/blogc</remote-id>
+ </upstream>
+ <use>
+ <flag name="git">Build blogc-git-receiver tool</flag>
+ <flag name="make">Build blogc-make tool</flag>
+ <flag name="httpd">Build blogc-runserver tool</flag>
+ </use>
+</pkgmetadata>