summaryrefslogtreecommitdiff
path: root/app-text/bibutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /app-text/bibutils
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'app-text/bibutils')
-rw-r--r--app-text/bibutils/Manifest2
-rw-r--r--app-text/bibutils/bibutils-6.7.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/bibutils/Manifest b/app-text/bibutils/Manifest
index 7130e5022b88..61fa63bbc4f1 100644
--- a/app-text/bibutils/Manifest
+++ b/app-text/bibutils/Manifest
@@ -1,3 +1,5 @@
DIST bibutils_4.12_src.tgz 447566 BLAKE2B 64d185963028f29f4efb64c63ee6ddb59961744d525d4dbaf28bdd1edb28ac8ea86529082995d11245c258895f27457c9d01594564a44caa837b0ba76052b969 SHA512 04329ecb685bf4d5314c6d3a2d5bb21e67112d73bcb49f5a7808a4082f32a9aecb40add4ec4b5320be35f49cd8e101dc1e35409e7c6cad8c39238d2122f91dd0
+DIST bibutils_6.7_src.tgz 580792 BLAKE2B 29c5863bc414ef7b2f362d95352c0e042c1bcc3275017df82b0206d96520b3f5c3fe1e12563577b84a8bd94b0677bf1ad04ecbd80dcbcc194a71037bbd6facba SHA512 08db07408eee26bce42dbd00b7e821ef41dc12c7ce847425e81145927bcfc6ea7180ff719056e089917811aa9675a09dd52e1e02b8187b8618f67647efcb1236
EBUILD bibutils-4.12.ebuild 1005 BLAKE2B 955eda004f2aa8378f379079bb0f5d2cfa64ab97bc95c6368ed432855b22152c4cb48e3f92604e17abb1ebd3ba560f2af542a3c24ff77069f5b56edb7a90be03 SHA512 fa3c470b226c04c7b3d4d1311ba44ee0eca3d70d34efcb4d69a11f1a6da85e94bf352fde88a76400a4cfbb3133b761bb71c4c45d9113775efa0e538ea390a61e
+EBUILD bibutils-6.7.ebuild 1359 BLAKE2B cff84426b4f5b8785d6990105923bcacf9e69537467c6bb291b84a216e0e10d17c5050a776c971b1ce7450ebe2c8ce867d667ace12cddc9da6177f54b27d9fe5 SHA512 9227cd90f15fb41be41adacb05a6c642abdabbef49ebb2ed0176c4014b9a06d889ec8cdc8e12e2899c324660ffc776d8954d5f3f016ef97a42097a946c77b309
MISC metadata.xml 249 BLAKE2B 03207049d5e7c62319639b2c37769d9d8c0d9cbf1e44fbc6cab9ea006e60bff3526193fea60902a0e64a362b02463104969700074602e31d8fb8f86a042d1ed8 SHA512 29a9c1817fd4299246d5fa995b73b9f1996b112b70f468139cf9cd8f07077d831e0788d3b93aaba67bb38dce5850830c27543fccbddbac02b0da4ff899def519
diff --git a/app-text/bibutils/bibutils-6.7.ebuild b/app-text/bibutils/bibutils-6.7.ebuild
new file mode 100644
index 000000000000..0b626bb59e52
--- /dev/null
+++ b/app-text/bibutils/bibutils-6.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
+HOMEPAGE="https://sourceforge.net/p/bibutils/home/Bibutils/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # The custom configure script still sucks several releases later, so we'll
+ # just do its job ourselves
+ rm -f Makefile configure || die "Failed to purge old Makefile"
+ sed \
+ -e "s:REPLACE_CC:$(tc-getCC):g" \
+ -e "s:REPLACE_EXEEXT::g" \
+ -e "s:REPLACE_LIBTARGET:libbibutils.so:g" \
+ -e "s:REPLACE_LIBEXT:.so:g" \
+ -e "s:REPLACE_CFLAGS:${CFLAGS}:g" \
+ -e "s:REPLACE_CLIBFLAGS:${CFLAGS} -fPIC:g" \
+ -e "s:REPLACE_RANLIB:$(tc-getRANLIB):g" \
+ -e 's:REPLACE_POSTFIX::g' \
+ -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
+ -e "s:REPLACE_LIBINSTALLDIR:\"${D}/usr/$(get_libdir)\":g" \
+ -e 's:make:$(MAKE):g' \
+ Makefile_start > Makefile \
+ || die "Failed to set up Makefile"
+
+ cp lib/Makefile.dynamic lib/Makefile || die
+ cp bin/Makefile.dynamic bin/Makefile || die
+ cp test/Makefile.dynamic test/Makefile || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install
+ dodoc ChangeLog
+}