summaryrefslogtreecommitdiff
path: root/app-text/bibutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /app-text/bibutils
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'app-text/bibutils')
-rw-r--r--app-text/bibutils/Manifest2
-rw-r--r--app-text/bibutils/bibutils-7.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/bibutils/Manifest b/app-text/bibutils/Manifest
index aa83230f675b..de4815399dca 100644
--- a/app-text/bibutils/Manifest
+++ b/app-text/bibutils/Manifest
@@ -1,3 +1,5 @@
DIST bibutils_6.10_src.tgz 590002 BLAKE2B 91ea6c961978d381a65c1d5071c541409609dd9fdeb664cd7e66eb4871c2ecd0dfd6b06857294ae6ec049751a5939be23518782a5e1f14fdf848918849269402 SHA512 43cf107ee6d1bf6bf27a6bf46e1f4cbd83a4b78ef355730a9f37282fac399ee21d78538248730be85c0a8f724344782dcc6ab68e50f857d8ac4ea24cc4102911
+DIST bibutils_7.1_src.tgz 620141 BLAKE2B f020ea7c8164a870ef4c72defae1adc11558661a7ae9f3b037115cfc4a9e71b4f37c64f3b74641182300c3e921b8a0c309257a468b6b32f4fc2915e4a36f04d1 SHA512 2a155ca60c97d37941c860635d8e6920bd78de84452e1fee93a2f7331392f6a43f2c10055e84349bcac89314025d1524fd5cc73c47ad1613baa7baf2667c3f33
EBUILD bibutils-6.10.ebuild 987 BLAKE2B 121e71d7e351135fc1d70b3c56706d68d74e8b4f454806e1211f3e428b9d617e885f7d8fd909121b7d6a78e5d82f4a2ecd37e7056f8f4204a8b8dc7b6581efa8 SHA512 04c331b7c4e54dbab631e27ddf2281a6bd8dcb332cbdf212b7adc5ccce61186b920b00f5fbaf231eb5bbad8c613e4f2aeafc5e385a9473310bdcf590a5af624b
+EBUILD bibutils-7.1.ebuild 937 BLAKE2B a39e4fe782440da07b0d59ee6d79fd89bbdcadc92eda5dcff60a2bcd5e243bf8280ef05fcff7776f65e51b60fb8cdbb62ee0120cf57e75cdb9aba1467177254b SHA512 44cf38673e6f7409846122ddb3ed24db1546542c8765c2465a54e58e56f8783ff445fdada3d4441976f7b309c758c483758c46326f57855a2b9417330a1114e8
MISC metadata.xml 332 BLAKE2B 543aa8ae8a86a9dce2bed1f5bb05f2f960725d137c638b33ff8a9a33407ae3d50cf96fffde54fb16af359cbe6bc301241c68e5fff46f100b3e0fb97143c81c80 SHA512 dbdbf756fc639e73aa5c0a92df6a873f4ef4feaa6bd0c636d178dd5ef21e59a86872774f06d5c48eb1f1e1dffef16ab9d2cc3973804eb33e111b451f87cab11b
diff --git a/app-text/bibutils/bibutils-7.1.ebuild b/app-text/bibutils/bibutils-7.1.ebuild
new file mode 100644
index 000000000000..a54bd087935e
--- /dev/null
+++ b/app-text/bibutils/bibutils-7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
+HOMEPAGE="https://sourceforge.net/p/bibutils/home/Bibutils/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ default
+ sed -ie 's/REPLACE_INSTALLDIR/${DESTDIR}&/' Makefile_start || die
+ sed -ie 's/REPLACE_LIBINSTALLDIR/${DESTDIR}&/' Makefile_start || die
+}
+
+src_configure() {
+ ./configure \
+ --install-dir /usr/bin \
+ --install-lib /usr/$(get_libdir) \
+ --dynamic || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}"
+}
+
+src_test() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}" test
+}