summaryrefslogtreecommitdiff
path: root/app-text/barcode/barcode-0.99-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-text/barcode/barcode-0.99-r1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-text/barcode/barcode-0.99-r1.ebuild')
-rw-r--r--app-text/barcode/barcode-0.99-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/barcode/barcode-0.99-r1.ebuild b/app-text/barcode/barcode-0.99-r1.ebuild
new file mode 100644
index 000000000000..9defd1531f06
--- /dev/null
+++ b/app-text/barcode/barcode-0.99-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="barcode generator"
+HOMEPAGE="https://www.gnu.org/software/barcode/"
+SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="app-text/libpaper"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-install-static-lib.patch
+)
+
+src_prepare() {
+ sed -i -e '/^LDFLAGS =/s:=:+=:' \
+ -e "/^aLIBDIR/s:lib:$(get_libdir):" \
+ -e '/^INFODIR/s:info:share/info:' \
+ -e '/^MAN/s:man:share/man:' \
+ Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ econf --disable-shared
+}