summaryrefslogtreecommitdiff
path: root/app-text/bact/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
commitd32022e7301aef2b3f52f6b7a3de81c6e03ffcaf (patch)
tree4e64fbab713348c061644255d893ff91f2d8b1e5 /app-text/bact/files
parent92f98ae772a60a2fa63efbda2f915da957a3b3b8 (diff)
gentoo auto-resync : 21:11:2022 - 01:03:25
Diffstat (limited to 'app-text/bact/files')
-rw-r--r--app-text/bact/files/bact-0.13-cpp14.patch48
-rw-r--r--app-text/bact/files/bact-0.13-makefile.patch38
2 files changed, 85 insertions, 1 deletions
diff --git a/app-text/bact/files/bact-0.13-cpp14.patch b/app-text/bact/files/bact-0.13-cpp14.patch
index fa083c223b12..a0f6edda1eed 100644
--- a/app-text/bact/files/bact-0.13-cpp14.patch
+++ b/app-text/bact/files/bact-0.13-cpp14.patch
@@ -1,6 +1,7 @@
Fix C++14 compilation errors -- since C++11 make_pair<T1,T2> is resolved to
make_pair(T1&&, T2&&). Types should be deduced.
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=594312
+
+Bug: https://bugs.gentoo.org/594312
--- a/bact_classify.cpp
+++ b/bact_classify.cpp
@@ -42,3 +43,48 @@ Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=594312
ary.push_back ((Darts::DoubleArray::key_type *)it->first.c_str());
alpha.push_back (a);
}
+--- a/darts.h
++++ b/darts.h
+@@ -394,10 +394,10 @@
+ {
+ if (! len) len = LengthFunc() (key);
+
+- register ArrayType b = array[pos].base;
+- register ArrayUType p;
++ ArrayType b = array[pos].base;
++ ArrayUType p;
+
+- for (register size_t i = 0; i < len; ++i) {
++ for (size_t i = 0; i < len; ++i) {
+ p = b + (NodeUType)(key[i]) + 1;
+ if ((ArrayUType)b == array[p].check) b = array[p].base;
+ else return -2;
+@@ -414,8 +414,8 @@
+ {
+ if (! len) len = LengthFunc() (key);
+
+- register ArrayType b = array[pos].base;
+- register ArrayUType p;
++ ArrayType b = array[pos].base;
++ ArrayUType p;
+
+ for (; pos2 < len; ++pos2) {
+ p = b + (NodeUType)(key[pos2]) + 1;
+@@ -437,12 +437,12 @@
+ {
+ if (! len) len = LengthFunc() (key);
+
+- register ArrayType b = array[pos].base;
+- register size_t num = 0;
+- register ArrayType n;
+- register ArrayUType p;
++ ArrayType b = array[pos].base;
++ size_t num = 0;
++ ArrayType n;
++ ArrayUType p;
+
+- for (register size_t i = 0; i < len; ++i) {
++ for (size_t i = 0; i < len; ++i) {
+ p = b; // + 0;
+ n = array[p].base;
+ if ((ArrayUType) b == array[p].check && n < 0) result[num++] = -n-1;
diff --git a/app-text/bact/files/bact-0.13-makefile.patch b/app-text/bact/files/bact-0.13-makefile.patch
new file mode 100644
index 000000000000..d27879559d1d
--- /dev/null
+++ b/app-text/bact/files/bact-0.13-makefile.patch
@@ -0,0 +1,38 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,6 @@
+-CXX = c++
+ VERSION = 0.13
+-CXXFLAGS = -O3 -Wall -Wno-deprecated
++CXXFLAGS += -Wall -Wno-deprecated
+ EXECPREFIX =
+-LDFLAGS =
+ TARGETS1 = bact_learn${EXEC_PREFIX}
+ TARGETS2 = bact_classify${EXEC_PREFIX}
+ TARGETS3 = bact_mkmodel${EXEC_PREFIX}
+@@ -10,14 +8,11 @@
+
+ all: bact_learn bact_mkmodel bact_classify
+
+-bact_learn: bact_learn.o ${OBJ}
+- ${CXX} ${CFLAGS} ${LDFLAGS} -o ${TARGETS1} ${OBJ} bact_learn.o ${LDFLAGS}
++bact_learn: ${OBJ}
+
+-bact_classify: bact_classify.o ${OBJ}
+- ${CXX} ${CFLAGS} ${LDFLAGS} -o ${TARGETS2} ${OBJ} bact_classify.o ${LDFLAGS}
++bact_classify: ${OBJ}
+
+-bact_mkmodel: bact_mkmodel.o ${OBJ}
+- ${CXX} ${CFLAGS} ${LDFLAGS} -o ${TARGETS3} ${OBJ} bact_mkmodel.o ${LDFLAGS}
++bact_mkmodel: ${OBJ}
+
+ clean:
+ rm -f *.o ${TARGETS1} ${TARGETS2} ${TARGETS3} core *~ *.tar.gz *.exe core* med.model* jp.model*
+@@ -33,7 +28,6 @@
+ scp bact-${VERSION}.tar.gz index.html bact.css chasen.org:public_html/software/bact/
+
+ check:
+-test:
+ ./bact_learn -T1000 med.train med.model
+ ./bact_mkmodel -i med.model -o med.model.bin -O med.model.O
+ ./bact_classify med.test med.model.bin