summaryrefslogtreecommitdiff
path: root/app-text/atril
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-text/atril
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-text/atril')
-rw-r--r--app-text/atril/Manifest2
-rw-r--r--app-text/atril/atril-1.22.0.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/app-text/atril/Manifest b/app-text/atril/Manifest
index a4b7deaa5500..90a470674b2d 100644
--- a/app-text/atril/Manifest
+++ b/app-text/atril/Manifest
@@ -1,3 +1,5 @@
DIST atril-1.18.3.tar.xz 1695960 BLAKE2B 2479ddd46104153631d34070054e9ba72956468c7b720aa5dc3c4a458a00cc00484cdfefb01981f2e8beeb7a13f1fc3db940dcc9a728863a1378b5b896e71e57 SHA512 d57cf4386651cb871455b003482e896a2735fb023e0b11f192ed1d169e364306f9ba55ef163df02ffd236b5f86d6afe2c1068d00d3fbc309807ded729ce2355a
+DIST atril-1.22.0.tar.xz 1819580 BLAKE2B 6d5ae9e42407c5c7ae716c0650eda2085bc2206f442dbbb04dbf549263cdabe6d28761deb14bb9557534f26828882cf5b9373698b5e2c29f4b70445ebfabaa5b SHA512 bf940178647c348fd78e828bcb3a55c4ff6195d4020bf198ae5ba4a96e2fe582f7e30fb9d4cde4143e82ae783358373d3a9fd68413295586da9fe1b374e2f034
EBUILD atril-1.18.3.ebuild 2164 BLAKE2B b846318383a8a5c62e7c48807172df259df46254d95eb64d962884c26decad08bf5023b6c07bf64c23a29ca534421daed0c2951d41b96f828a9ccd78e088974a SHA512 6c9782e6bd88b3258a54cbd4f31115f6527fd91a745c587ca872f9956afc6cb752b651aab86c18b563f935e469873efe780dc5965c6c6d3f2001cb3ca72a1a97
+EBUILD atril-1.22.0.ebuild 2137 BLAKE2B 43f5aa8fce52eab71cdee4de3c08627ee97fbdf7a5eb930bea44376a0f2965cebe8c4ea35781d31e22ba73d9a6dba7ca20826ef32a1c3ee6ab47b321b6572bb3 SHA512 53c279f7beb15f09ccb0a2aa6d3d2d999d541176997e9768deb2ed00854d7591e1c50775a8f6126407f934623d3af67f9f435ccf22c276d3befa3f313f50fcec
MISC metadata.xml 782 BLAKE2B f87378442b88dfae4c1b06d6bfc3f3d13770271bb0c589ad37965325bdc0ac13cdbea3dc18fb41d48339a078c2d11c0adfa78a88da9216356c79fece0f5f39d9 SHA512 d3c0b43a5957c49d606b8eafd71ec8a0ef3e428e1953a0e8172c633bede7c9e1d468cf61eecb2f6cd980ff64ab02faf16c9501351ccebbc64175af9fb9b32477
diff --git a/app-text/atril/atril-1.22.0.ebuild b/app-text/atril/atril-1.22.0.ebuild
new file mode 100644
index 000000000000..6ccb2b4d54db
--- /dev/null
+++ b/app-text/atril/atril-1.22.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Atril document viewer for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="caja dbus debug djvu dvi epub +introspection gnome-keyring +postscript t1lib tiff xps"
+
+REQUIRED_USE="t1lib? ( dvi )"
+
+COMMON_DEPEND=">=app-text/poppler-0.22[cairo]
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ >=x11-libs/libSM-1:0
+ x11-libs/libX11
+ >=x11-libs/cairo-1.9.10
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1[introspection?] )
+ djvu? ( >=app-text/djvu-3.5.17:0 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5:5 )
+ )
+ epub? (
+ dev-libs/mathjax
+ >=net-libs/webkit-gtk-2.4.3:4
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6:= )
+ postscript? ( >=app-text/libspectre-0.2 )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.2.1 )
+ !!app-text/mate-document-viewer"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/rarian
+ app-text/yelp-tools
+ >=app-text/scrollkeeper-dtd-1:1.0
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig:*
+ sys-devel/gettext:*"
+
+# Tests use dogtail which is not available on Gentoo.
+RESTRICT="test"
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ mate_src_configure \
+ --disable-tests \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-previewer \
+ --enable-thumbnailer \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable caja) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable epub) \
+ $(use_enable introspection) \
+ $(use_enable postscript ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}