summaryrefslogtreecommitdiff
path: root/app-text/asciidoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /app-text/asciidoc
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest2
-rw-r--r--app-text/asciidoc/asciidoc-9.0.4.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 5de60b308cd5..e49c15742852 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,3 +1,5 @@
DIST asciidoc-9.0.2.tar.gz 1144308 BLAKE2B 5f5deca6b8c15d4b86e2bd6fdb131908eecd862a5fdbbd8418937050d335a25ad012a3b1bc716379f5623db676176fc6da1a09691c2b42a213a6230281626b69 SHA512 ea8f64ce54d2f1aa38eceb3c1c9be17b388776de58038f3b888ac5ebed76337fa2779e43eb7f47174adf0a0446ee808dbd1e4f8f7e1d7db99db7c4c8584d5624
+DIST asciidoc-9.0.4.tar.gz 1111102 BLAKE2B 3c073e20e0b4cb1c3e43d45217240675d5a1349c5d27c8e03c4499505c17ad0a149f9495a42e28490f9c89f29dc25a1216e9145a6fd1483e589b5fee49a6279f SHA512 9e24aaaf33ab56cf1dfa510a6be9722af364633234c9ffb20eeee3d0ba756059290f443de53b040570654a316ab4782a177c31377fc69747814da75760fcc88b
EBUILD asciidoc-9.0.2.ebuild 2350 BLAKE2B 00b0c901aa6e0afc605d9aab86fb92c61257031b6f5307e412bd33e006b5475d9d8b3ebe8975c5199cd5074fb40200fb80e1642d56bfa3991f3f0793fe8c82c6 SHA512 64d685ce15c063c58426fec009941c7ba90efb6367bd9b109e1f53e5c53df152fcc169c9e5e15a2b8963cbf6d351ef5ab3112c88b5cf5ca4c6689e20fcf82315
+EBUILD asciidoc-9.0.4.ebuild 2359 BLAKE2B 73483e2f453863fb082197713c8332572defb7c97ec1d1b4bfdc34c6da70f374cbf6b613d8245e803fd831c95636dbd7b1181eac0bb7c9e27560d3be2c926553 SHA512 d8187de4533f6fc9357d1fc7de72ee948956d02c0473f0273b172a833e86973f6f7160956886a291b5214795de29d13c4125e222f34052a07677edcc1cfef123
MISC metadata.xml 435 BLAKE2B c6a62f25ed62fc8bb28f94a51985d44a2b048eed430d1e92670bf257039c15ccf741414f9c64f3a60220217fd8c2e995910c611890664f0118541996d7b9c9d3 SHA512 b18f244fd4bce0103b7a3c6a5d1e063d45fd1f17458d9a8c4cb2b6543bb38d7bb7047105be81b39d309ff0c3d9343e36df44345f31e32c348fc8aff30ef6d837
diff --git a/app-text/asciidoc/asciidoc-9.0.4.ebuild b/app-text/asciidoc/asciidoc-9.0.4.ebuild
new file mode 100644
index 000000000000..bc94bbefaca5
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9.0.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit autotools optfeature python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc/asciidoc-py3/"
+SRC_URI="https://github.com/${PN}/${PN}-py3/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+ "
+DEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ app-text/dvisvgm
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick
+ media-sound/lilypond
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
+ docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
+ filters/code/code-filter-readme.txt )
+
+S="${WORKDIR}/${PN}-py3-${PV/_/}"
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ asciidoc.py || die
+
+ # enforce usage of the configured version of Python
+ sed -i -e "s:python3:${EPYTHON}:" Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ emake DESTDIR="${D}" docs
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
+ optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments app-text/highlight
+ optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "\"graphviz\" filter support" media-gfx/graphviz
+}