summaryrefslogtreecommitdiff
path: root/app-text/antiword
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/antiword
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/Manifest5
-rw-r--r--app-text/antiword/antiword-0.37-r1.ebuild50
-rw-r--r--app-text/antiword/files/antiword-0.37-CVE-2014-8123.patch17
-rw-r--r--app-text/antiword/metadata.xml12
4 files changed, 84 insertions, 0 deletions
diff --git a/app-text/antiword/Manifest b/app-text/antiword/Manifest
new file mode 100644
index 000000000000..8c0e8adaedac
--- /dev/null
+++ b/app-text/antiword/Manifest
@@ -0,0 +1,5 @@
+AUX antiword-0.37-CVE-2014-8123.patch 528 BLAKE2B 612718b3af9f3e91b5b755401a124c65268c482075b4f96ea71260f63e43d8fc5a1e009dce5a6ec527a56e013e4627855ea20259a6d72154e51ca0abf870554b SHA512 412884a236abb5ee75e5c707581c7e0158614d0e168cd9a8fe02dd8dcb8c0963ae2269c9575cd9cb9f4876efb3bec6bef7934fec5c7738530012495637a2d694
+DIST antiword-0.37.tar.gz 317884 BLAKE2B f47c815e2c6a1ddb33fefa33b3579fa5ba6e3900d3b9339350d28ebd0223853ad60ed717a1bccf4960c835427ebacc4de944548f9b354cd34889f0742de4e74a SHA512 6cd8fb9137238417544cf8754829a2d5296055d730ea62a8a025236baa79516190317d146401ff40cde73e1ee2c3c374a2ea01b2e5d24e149310bcabb8bfdce8
+DIST antiword-gentoo-patches-r2.tar.bz2 1747 BLAKE2B c01aa7c02539fb5148cb1ec01983a8406315bc3cb2f909118c022c2f218660919e6862582cda34dbd4c08a21beb02c928f685273853d1ff3350548957ae30cde SHA512 45ed3ee1c514a9ee78bc8963e56be18426b47ea628f02934dbcec83c2d632162e458f75f998da438daae4794fcce36fd8922a172804c0fc83c6f32c9a8092ffe
+EBUILD antiword-0.37-r1.ebuild 1431 BLAKE2B 2367955fe72a8c5d31e86fc8fb9303b858f4605e07d02458f63ce8d66fc35179e1ab5a6679cc31ea57f93f3e412dfef48e370b74384e4240f72741e64fbb7c8b SHA512 fdc188c4658e1093e4f843711a1843da8e827f1c737a627e54000bb3b4d16827eb828c52019b64adaca2fcfb20e6f57b29271f8d7c21241fc7fd9878c0204585
+MISC metadata.xml 343 BLAKE2B a255d4f9a7079612cf94d69b3136bf3dc5d1ac638629e02430c96512b039fbaa0d1d05a216f7181c7269a1701c096292e47251769581d1f4dc5bb1559c76501a SHA512 6a09982bb72f873e6fcfc90d8dcb8db7b06c11b43633793303f511b5bdc86f83a2b2ab560f6ce1e4b62e334c16cce96fd9b0ad983caee6381612a4b4102ccc09
diff --git a/app-text/antiword/antiword-0.37-r1.ebuild b/app-text/antiword/antiword-0.37-r1.ebuild
new file mode 100644
index 000000000000..7aafe949cf22
--- /dev/null
+++ b/app-text/antiword/antiword-0.37-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+IUSE="kde"
+PATCHVER="r2"
+DESCRIPTION="free MS Word reader"
+HOMEPAGE="http://www.winfield.demon.nl"
+SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/${PN}-gentoo-patches-${PATCHVER}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ~arm ~hppa ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+src_prepare() {
+ # Makefile is a symlink to Makefile.Linux, avoid that we patch it by
+ # accident using patch <2.7, see bug #435492
+ rm Makefile || die
+
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${PN}-gentoo-patches-${PATCHVER}"
+
+ # Re-add convenience symlink, see above
+ ln -s Makefile.Linux Makefile
+
+ epatch "${FILESDIR}"/${P}-CVE-2014-8123.patch
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake PREFIX="${EPREFIX}" OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install || die
+
+ use kde || rm -f "${ED}"/usr/bin/kantiword
+
+ insinto /usr/share/${PN}/examples
+ doins Docs/testdoc.doc Docs/antiword.php || die
+
+ cd Docs
+ doman antiword.1 || die
+ dodoc ChangeLog Exmh Emacs FAQ History Netscape QandA ReadMe Mozilla Mutt || die
+}
diff --git a/app-text/antiword/files/antiword-0.37-CVE-2014-8123.patch b/app-text/antiword/files/antiword-0.37-CVE-2014-8123.patch
new file mode 100644
index 000000000000..8b6baf9b2ca2
--- /dev/null
+++ b/app-text/antiword/files/antiword-0.37-CVE-2014-8123.patch
@@ -0,0 +1,17 @@
+index 8a95fb9..7797d1f 100644
+--- a/wordole.c
++++ b/wordole.c
+@@ -259,6 +259,11 @@ bGetPPS(FILE *pFile,
+ }
+ tNameSize = (size_t)usGetWord(0x40, aucBytes);
+ tNameSize = (tNameSize + 1) / 2;
++ if (tNameSize >= sizeof(atPPSlist[0].szName)) {
++ werr(0, "PPS %d appears to be invalid.", iIndex);
++ atPPSlist = xfree(atPPSlist);
++ return FALSE;
++ }
+ vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize);
+ atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes);
+ if (atPPSlist[iIndex].ucType == 5) {
+--
+2.1.2
diff --git a/app-text/antiword/metadata.xml b/app-text/antiword/metadata.xml
new file mode 100644
index 000000000000..8ee341cec0e5
--- /dev/null
+++ b/app-text/antiword/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:antiword_project:antiword</remote-id>
+ </upstream>
+</pkgmetadata>
+