summaryrefslogtreecommitdiff
path: root/app-text/antiword
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /app-text/antiword
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/Manifest1
-rw-r--r--app-text/antiword/antiword-0.37-r2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/antiword/Manifest b/app-text/antiword/Manifest
index 14e00f62a094..50414dd9daf8 100644
--- a/app-text/antiword/Manifest
+++ b/app-text/antiword/Manifest
@@ -2,4 +2,5 @@ AUX antiword-0.37-CVE-2014-8123.patch 528 BLAKE2B 612718b3af9f3e91b5b755401a124c
DIST antiword-0.37.tar.gz 317884 BLAKE2B f47c815e2c6a1ddb33fefa33b3579fa5ba6e3900d3b9339350d28ebd0223853ad60ed717a1bccf4960c835427ebacc4de944548f9b354cd34889f0742de4e74a SHA512 6cd8fb9137238417544cf8754829a2d5296055d730ea62a8a025236baa79516190317d146401ff40cde73e1ee2c3c374a2ea01b2e5d24e149310bcabb8bfdce8
DIST antiword-gentoo-patches-r2.tar.bz2 1747 BLAKE2B c01aa7c02539fb5148cb1ec01983a8406315bc3cb2f909118c022c2f218660919e6862582cda34dbd4c08a21beb02c928f685273853d1ff3350548957ae30cde SHA512 45ed3ee1c514a9ee78bc8963e56be18426b47ea628f02934dbcec83c2d632162e458f75f998da438daae4794fcce36fd8922a172804c0fc83c6f32c9a8092ffe
EBUILD antiword-0.37-r1.ebuild 1359 BLAKE2B 439002b6ce33a663b68c282770dbb3b43f86bb8e3255a8e15027c5a480f0642cfa71359be9628a5ca0a77520d1aa45ff337aa7c00902a77ed198941b0b06f6f5 SHA512 5ec8979802319c426e7899a56700bed2beecc656a5469b86f86cb353efe172cd221e0940f65457894b1af607b511459e947a02eb488b55ca27a8b2089df9e544
+EBUILD antiword-0.37-r2.ebuild 1336 BLAKE2B 5e7f7b96a93ee47c7114c46df7335327d4fcca53a1bb251179779fc08d80951cf5bce14c11ee0408f49dc91c6b176135acb6ecc409f5f0fe8e236a9a140c96f5 SHA512 f8dddea2b4b77cadd00c3a0fa38e63f79fe586a02f06596d1f755227758f041d2693ab8a55c9b2e1c0dce9295805059277ffa59b5dd0db8b8d0bd5d9b07189be
MISC metadata.xml 343 BLAKE2B 43a8dd808338ef2c570ac118c0600029bb805033af3f7e70d8b3afd7e9c685949c4b4e006e1c5bc51b72f9b8ab54104a0f9c731223d73dd5909f04a5bd964526 SHA512 184ff7031a9864c1ee3daa6c3714d148216f556fd112a62c1c2e352f3eef08bd6a1813dbb46dde3a163cc69f59f06ff99570460e4af1c2d4a31085b9aa7043ce
diff --git a/app-text/antiword/antiword-0.37-r2.ebuild b/app-text/antiword/antiword-0.37-r2.ebuild
new file mode 100644
index 000000000000..1b0fc3a45055
--- /dev/null
+++ b/app-text/antiword/antiword-0.37-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+PATCHVER="r2"
+DESCRIPTION="free MS Word reader"
+HOMEPAGE="http://www.winfield.demon.nl"
+SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/${PN}-gentoo-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-gentoo-patches-${PATCHVER}
+ "${FILESDIR}"/${P}-CVE-2014-8123.patch
+)
+
+DOCS=( Docs/{ChangeLog,Exmh,Emacs,FAQ,History,Netscape,QandA,ReadMe,Mozilla,Mutt} )
+
+src_prepare() {
+ # Makefile is a symlink to Makefile.Linux, avoid that we patch it by
+ # accident using patch <2.7, see bug #435492
+ rm Makefile || die
+
+ default
+
+ # Re-add convenience symlink, see above
+ ln -s Makefile.Linux Makefile
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}" OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install
+
+ einstalldocs
+
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc Docs/testdoc.doc Docs/antiword.php
+
+ doman Docs/antiword.1
+}