summaryrefslogtreecommitdiff
path: root/app-text/XML-Schema-learner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/XML-Schema-learner
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/XML-Schema-learner')
-rw-r--r--app-text/XML-Schema-learner/Manifest5
-rw-r--r--app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild37
-rw-r--r--app-text/XML-Schema-learner/metadata.xml24
3 files changed, 66 insertions, 0 deletions
diff --git a/app-text/XML-Schema-learner/Manifest b/app-text/XML-Schema-learner/Manifest
new file mode 100644
index 000000000000..f1dbe67cdd88
--- /dev/null
+++ b/app-text/XML-Schema-learner/Manifest
@@ -0,0 +1,5 @@
+DIST XML-Schema-learner-1.0.1.tar.gz 51057 SHA256 79e9416db683fee9463ba895283423661e05aa8de2b15c9ea2372c83110ab011 SHA512 f357c1a99ac6a7f807538910dfe5e19b14f789046816d333cb031addfbffc0858fd5641f52dcd7304417d0cf0b6c45d1eb3f2092652c4891c09fc45dd26feb9d WHIRLPOOL 810a51fa5920d46f96e82d018c95e9524dfc85b433fd1579f90a7ff241e6300dc88f166725e68f58a0aac1658fc92ba374da03e3995ed22ba08da23e6003df43
+EBUILD XML-Schema-learner-1.0.1.ebuild 990 SHA256 ab9ed2e82316867ba6fe56b356bda9008fd4c6f8dc413cb5e04f7965c918776a SHA512 578bb825228e78d83617ec19bd72def2443b3c39b00da1982aec26c0cdcd19e89e1bd792c406854044394cd4f2405ce7815960a63871f611ed4fe99f9fb4c621 WHIRLPOOL 52a79fb235053d21139fd76e86b7cdb4f59878eec5de55c3833868e655c989c16db8002bf81b41f1c34f88840efc611f75fca76dd67dcaf3197fcd5cab486a7d
+MISC ChangeLog 2427 SHA256 b4d974c7489286e1573da18c7d9a8a31b73db44070c1a17fc7ac3a7382c22c09 SHA512 900948e0cfd29eb323a7a5d2507f9c08a057a0dd06a030f17396d8111a50c98859c743fdd96eb4e34f45a55405ae7164f40f2eee2cb1f4b9fe1da0733f93988c WHIRLPOOL 564f1fd56970a9641826f32f09d65c9cbc60aeb49e95eea2a5074500f0f3b4031351e3c34019cc8472596202b48e73cd2bc9bb8aadc82811ca7c8610470b8fdc
+MISC ChangeLog-2015 1552 SHA256 e819a35f687a0841adac43660e625a1367b0ecfecb132ba9fd92b42f7504b3eb SHA512 183f116b77a06e2c5a3f4c56b704b836b41eb4802d2fcaa0e75098fa2f8bee1bff0eec79d34b1ce6a3f8adf09544a770860fbe706d09fb798fc63f00962e0001 WHIRLPOOL 7de57aab43d8e058ff441dd22e419ccd7748eec82fc19af4964bb48087cea2c8e66aafb9962769e5e1dc0895bf603e66035302ac6ea4f8511e13bd7f50d49f21
+MISC metadata.xml 942 SHA256 9b2f58fa129255110e5877b387f34afcb092d678cd3498cacb8d18b003ed0d9f SHA512 48e0d860bbede84a76773ad1a77620cdee393eb0894f63461371ae7cb12a43fa0b640bb2dee17eb3eeb22fbe24899c90da704a74f70075e722e83f5d0be86bb2 WHIRLPOOL 66e8bd2d9c2df4aa90224ccec086e984b0c715fe188bba068bd0358e48d4aec9c9c7584c01d3e52a0319eb0d64041d9cf981683186c7b0f24ab9a8d6cf890865
diff --git a/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild
new file mode 100644
index 000000000000..b4d56e1a79ba
--- /dev/null
+++ b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
+HOMEPAGE="https://github.com/kore/${PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+# PHP dependency can be inferred from .travis.yml in the repository.
+# The necessary USE flags on the other hand were found the hard way.
+#
+# The dependencies here aren't as expressive as they should be. What we
+# really want is for php[...] to apply to everything in PHP_TARGETS, and
+# for those interpreters (the ones in PHP_TARGETS) to be used to run the
+# test suite.
+#
+# See bug #497606.
+#
+RDEPEND="dev-lang/php:*[cli,xml,xmlreader]"
+DEPEND="test? ( ${RDEPEND}
+ dev-php/phpunit )"
+
+src_compile() {
+ # Don't run make, the default target is 'check'.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README.rst
+}
diff --git a/app-text/XML-Schema-learner/metadata.xml b/app-text/XML-Schema-learner/metadata.xml
new file mode 100644
index 000000000000..a1b8a8d91692
--- /dev/null
+++ b/app-text/XML-Schema-learner/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This software implements various state-of-the-art algorithms for
+ algorithmic learning of XML Schema definitions and Document Type
+ Definitions.
+
+ Given a set or a single XML instance it can algorithmically infer
+ a schema which describes the XML instances. The resulting schemas
+ are of high-quality and human readable.
+
+ The theory behind the project is described in Kore Nordmann's
+ thesis, "Algorithmic learning of XML Schema definitions from XML
+ data," available at
+ http://kore-nordmann.de/talks/11_03_learning_xml_schema_definitions_from_xml_data.pdf.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kore/XML-Schema-learner</remote-id>
+ </upstream>
+</pkgmetadata>