summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /app-shells
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin8792 -> 8794 bytes
-rw-r--r--app-shells/fzf/Manifest3
-rw-r--r--app-shells/fzf/fzf-0.31.0.ebuild72
3 files changed, 75 insertions, 0 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index 28fb1276a9ff..f6192d8fa207 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 07e93e616f49..b128eb830d63 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -1,4 +1,7 @@
DIST fzf-0.30.0-deps.tar.xz 20315772 BLAKE2B 8664b82f5e837bde97251f64e6d8637f20231138123a23626da5811dca12b3a0fcca9c0ad84dfa4f335c4d5667ef1a23b30d5c2624ab7d67541902f7b493fbb3 SHA512 2adb3b36a5f059a623a64eb89678d03686be0d1ceb7628b55ef8ffa7db024f69484361c3f0e04d915016ce7318a386d0c606180120cf30dce41fd2be2a5c6495
DIST fzf-0.30.0.tar.gz 209750 BLAKE2B ee21726dac11cddc29839c1c2368e46497b4b5172e8896914b8fda602ecb28a7179f27cb3c63d9841f42e87e7d3589b37427b348b9e59cf531797c487e3fdc2d SHA512 cebb685a7fa00bdff07751d0021edde82f0ff3bf705eff82f94f6bf57c5e008eb6894d023ed7b14378f1d92fa2394192c12b720c6f711b1a414438fe3f8b4ec3
+DIST fzf-0.31.0-deps.tar.xz 16051640 BLAKE2B 9aac02a1df4d9db7cf11c77dead32fb13b74965e0c38b4d5d650daff123a697091db93235c3a3f3325c91351cbaf4b5401cdeee8d5120a59bc83fa9a0ca763da SHA512 bd88603ce059cac3c10bcf4face50f8097d7efcc26ef8b61870f93e7405b849293c80e9d39e124a63103080b6bab0cc28225b85470bc650fc53c61aa5ae9f33d
+DIST fzf-0.31.0.tar.gz 210779 BLAKE2B 013ba0689e661a2497ffd3a6046ae330930aca295ad9b9620ab70474d34d969a78fccebb59daf45b278a76f33093db1fcd6838fb785aa63008755ce693b15967 SHA512 e0d281fe771a51d4bd617227daa9533e0d219cc047233ca9f342683591bc09843aad1d3686d58ddef71c317e69b2ccaf4a3d6175959cf81aaec50914fe51dea0
EBUILD fzf-0.30.0.ebuild 1757 BLAKE2B 009b962eccb17af6b8533d2c411030f050235e159988946ae775d3d1da7aab96360afc8ae9771e5ad4f0d0d3f605b2629b1be6eece989afa2f0fec5adfcf107e SHA512 be9f419f071a169b3754b34152da426bdd6f4213221d7d886b5a964e672fce0e12209b48d06c4f26d84696b56c418f41723c2a7462d4faff67eec9b96fa0a0aa
+EBUILD fzf-0.31.0.ebuild 1975 BLAKE2B 6b6e8a022a9e3c8ebe89d79b8af14ee738cb521f2bd8b31489dfd9f1f81295fefe76bc681287c96b665694f37e9e7bf3911034749e7746c963ce3c6ba3ea438a SHA512 0778f5a555dbcf764230a78fc54277a3442f9d0fd41086e23e83f428b43dd5e53903d84c118548fffdaf07110d6c450a974031582cbbbf41682dd034ab3142f6
MISC metadata.xml 469 BLAKE2B 3d6dcce756d040b715bbf17f33faea2c0ddd810857cb38289f59cab134a5b049d21db71c9c3844497643e1728ecd09a924a51ba273f736712543307f2b806d1a SHA512 21f3fef809b276da7f7ad33dbafefc2ebfa86b9ce9aa0dea664724c399a6743923a8a1825cffbd06d885181dc7b305d351e7ab77bd133abb98f601a84783f52f
diff --git a/app-shells/fzf/fzf-0.31.0.ebuild b/app-shells/fzf/fzf-0.31.0.ebuild
new file mode 100644
index 000000000000..0ca870be1c60
--- /dev/null
+++ b/app-shells/fzf/fzf-0.31.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=a0ef8987fb5374452d08f32352cfa6933371ee54
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from /usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}