summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /app-shells
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin7465 -> 7468 bytes
-rw-r--r--app-shells/bash-completion/Manifest2
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild7
-rw-r--r--app-shells/hstr/Manifest5
-rw-r--r--app-shells/hstr/files/hstr-1.24-tinfo.patch11
-rw-r--r--app-shells/hstr/hstr-1.23.ebuild4
-rw-r--r--app-shells/hstr/hstr-1.24.ebuild2
-rw-r--r--app-shells/zsh/Manifest3
-rw-r--r--app-shells/zsh/zsh-5.5.ebuild211
9 files changed, 224 insertions, 21 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index 294d25e3c0a0..aa73f61bed1a 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 0b67c4561044..d90971e580a6 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -4,5 +4,5 @@ DIST bash-completion-2.7.tar.xz 280048 BLAKE2B 88b09f451fd4e14daf8e139951a4b65aa
DIST bashcomp-2.0.2.tar.gz 3625 BLAKE2B ebd835e23634e8a7491467ad66c53941763cea43bad75fe24982d3885be2d2ba132e5273a655fec34705224315d7a3f0248c030fb7685fc613ac4f489cde5bf5 SHA512 46bc1bcc32263135f44be68569459a409250dd2c81c18190735f11e13a26508e9d3cb91d24a8fe7b21bdea678347873b7ac1b67d5e8c78c8444011f85dfdcdce
EBUILD bash-completion-2.4-r1.ebuild 3161 BLAKE2B 0c3b185bb625c951f47fb9571695ac67900d67868a0bab27d1a80cb15a31e997422fa8e43677f4d68c6644e10f502c25fad166e1ad1257696c9795bcdc2967c0 SHA512 2d6366a7609d3fab9a423fac06e2c78957f079c37a9c69d9694dac6f70ed50d4234b14f4fb54dda303ef916ec6f92402179b6bb2830208d83e6c5e98bacfb693
EBUILD bash-completion-2.7-r3.ebuild 4115 BLAKE2B add51db8aeec357866a04e9bd3847c1c0624e5f3471aadd014b0d58475ab8a1b7ee59a5f9a8777ef4ef162958b969f4a6fa46ae75466917b92bb03397855ba3c SHA512 bf138c8f7bd20fe5f1803a6b96b435ec2b0f7b5be28b2d14aab545425b8659d254a4bfca8e92d687266730ff75479b1e59f69cfc022c582cb094852c4ef1a3bc
-EBUILD bash-completion-9999.ebuild 3911 BLAKE2B d574df4426904b68d44dbd724f0dd60e5b6b1b46ca5b2277c6095f8f21780e660d4e7981cb581d51237ed728f9f5837363fc2e05ec7b523f1e0c38c6c680b0af SHA512 1defdc4182a89d0d4a1f6c21c411cf9bbd4cf92b6a86667b29c08dc2112618e33284fc6ff24bac5e0b306edcc207a5538d911c0fb1dff2d01fc67c995d3e3d70
+EBUILD bash-completion-9999.ebuild 3966 BLAKE2B fb35f3822108eabcd36264cdc2eb0c386f99bfcd6df5a4bddeb5a0e7a110f7ca598507169adff6aadeee3ea678547ef974792d97091ac99e666cd5783a0d8ca3 SHA512 f4db656cac0725c95e1acca37b2ce0fda2bd49d1bc07249f0204c9434a1fee517761f6d00ff0863e608ad070d1f7a6a93882f2663b5ae24ad87e902460a4d159
MISC metadata.xml 1309 BLAKE2B db08060cd74841bd7220e688e251225ddaf59e4da737c08785e7c6ce83c2d40600fbe38e9b9449fb559ccb2d03b8c2368295b647ec2a52191429fe1d3d1c7470 SHA512 3ee23fb6cbee1e80a0c8fab13f7bb67bdad3292fa8ec187e306b00804a7bf709358c8c08eda4101a5f5baa408e0892aa94c07ae466b5beae4edc18055b1192ee
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 10f64b1c2271..1ef70643b1e9 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -45,8 +45,8 @@ STRIP_COMPLETIONS=(
# Now-dead symlinks to deprecated completions
hd ncal
- # Installed by sys-apps/util-linux-2.28
- mount umount mount.linux umount.linux
+ # Installed by sys-apps/util-linux-2.28 (and now deprecated)
+ _mount _umount _mount.linux _umount.linux
# Deprecated in favor of sys-apps/util-linux-2.31
_rfkill
@@ -95,7 +95,8 @@ src_install() {
local file
for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ rm "${ED}"/usr/share/bash-completion/completions/${file} ||
+ die "stripping ${file} failed"
done
# remove deprecated completions (moved to other packages)
rm "${ED}"/usr/share/bash-completion/completions/_* || die
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index 3892c2e16480..388ae8737fed 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1,7 +1,6 @@
AUX hstr-1.23-tinfo.patch 481 BLAKE2B 3279671caf216d810c3fef490c5ae219906e59430dc15a850118bbafe49140f46fb1645be1c0a8a8977c795af018164027f928d4fcb0a664186c97f2b968edfb SHA512 64c1e0a5b2ee28354f85563472dd301a9e45eb568fe74c0d601765ee25095650320b8f853c95280f294f323eec6b7f9a155c2a09a5fde2e52568d2c9809c1e91
-AUX hstr-1.24-tinfo.patch 481 BLAKE2B 3279671caf216d810c3fef490c5ae219906e59430dc15a850118bbafe49140f46fb1645be1c0a8a8977c795af018164027f928d4fcb0a664186c97f2b968edfb SHA512 64c1e0a5b2ee28354f85563472dd301a9e45eb568fe74c0d601765ee25095650320b8f853c95280f294f323eec6b7f9a155c2a09a5fde2e52568d2c9809c1e91
DIST hstr-1.23.tar.gz 47239 BLAKE2B dec630f1e8161edc40544561dd85ea1c128a6704eeeaeb39eb6987bdc096a070c9e242b938bed01b80e208aadf08606518a007919d353f76ff1c36e7906aeabb SHA512 234c72587d0492d788b1c001b5e53f74820790a9ebe670e8abd28cd82fc7db65996d54160e675055be54cab110686838fe6e36dbefe0fbef9175613633bc5910
DIST hstr-1.24.tar.gz 47523 BLAKE2B 6e84ea6bd26cb0745f48e5f8701d4d956ae4b83ed825398fdc401fd0b7f13eb9874de62d438e71a57fa048a535a538504e7fabd7b4a698665a10a901e0a570e6 SHA512 fe522374e33150007c0bbe5d11d38e63c355519350f5777c8787aae62826553b61a358185994d196d015590649fb3accf75948e340233459409d594e51874658
-EBUILD hstr-1.23.ebuild 631 BLAKE2B d3eb2ade2c30a1e61cc58349e52fe33d76ddb14ca490416aae276b106961287d79c1546b48ba8d56396ea84f95d741b1931b19516cc3e4a173398b644b75b99d SHA512 355201bac2ed090066c79e2c4d6d195510c28a18dd7105a0d23142724292221f2bdeb8f70de0db4ca6f2ae43e59969201110b00f4a461b49fe776f34d790042f
-EBUILD hstr-1.24.ebuild 633 BLAKE2B bbc75b9a1bd56c66ef62fab66bd760275695518e0a59b162d41525a78f6ff4bedb8022edc7276067c943c2d6eb283363377bbd7902f7d70dd30b92043a28c91d SHA512 b3e86724596618d75b6d8cd8dff17ec2d1111b1f3e3a2cd89a1934df1a0c6726894a6c78dd9e2b0d78d86f71d95017674fabc3ec59e66677f4a2d40b8bcf5308
+EBUILD hstr-1.23.ebuild 637 BLAKE2B f1af596ccaa3c5460acc5b8f49e5b38f529e7a86393ed5929ee67efaf67aed9ce2bc0242ef2696d58c88360a31ae56a046289e0978b2b61f1498d88947f2d917 SHA512 890b59a4e75d3bb1d11a586c9b8e840bc4303ea14520d4a9f7b877c7eb39661ff86bd38a81b2900f12ee05439ea0535595983021cfe4f12a5d38ec84b54a98c3
+EBUILD hstr-1.24.ebuild 639 BLAKE2B d8dd06c98a24245775915829f378a8561f97dfb11c076bf74cdae5d765ad7f66cc9119ba8ce7472102ee269b4d919c6320137a9df11ea2308ef5602fd43ef13c SHA512 a5ef7818c2e7f77e34d8f3c8612d626609cea02bf9f8d30da00a2a2dfa390cd782ef89feb0517ab7a08360782351436502510a45131baf39df5171521b418bff
MISC metadata.xml 453 BLAKE2B f0d991ae15d9b76c28a58f73be00cbb4824451019e9ef2858611681c4472c13cc4367166a130b3a313ac8ecafb859593610c52dab6c0cb7783ab079e31abeb27 SHA512 07997cef95d27c283b525f9a09d2762338c5bc8c2129904672cabf85e0d441ef7dc9b06608c0d38f0ae8d5d86e3fe8fc22bf8ebc7b29a81f8e9469436e62cf3e
diff --git a/app-shells/hstr/files/hstr-1.24-tinfo.patch b/app-shells/hstr/files/hstr-1.24-tinfo.patch
deleted file mode 100644
index 85a4743c0e94..000000000000
--- a/app-shells/hstr/files/hstr-1.24-tinfo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -76,7 +76,7 @@
- AC_CHECK_LIB(m, cos, [], [AC_MSG_ERROR([Could not find m library])])
- AC_CHECK_LIB(readline, using_history, [], [AC_MSG_ERROR([Could not find readline library])])
- # ncurses might be linked in libtinfo
--#AC_CHECK_LIB(tinfo, keypad, [], [AC_MSG_ERROR([Could not find tinfo library])])
-+AC_SEARCH_LIBS(keypad, tinfo, [], [AC_MSG_ERROR([Could not find tinfo library])])
-
- # Checks for header files.
- AC_CHECK_HEADER(assert.h)
diff --git a/app-shells/hstr/hstr-1.23.ebuild b/app-shells/hstr/hstr-1.23.ebuild
index cc9f3fc66fad..6fbe6ef2f86a 100644
--- a/app-shells/hstr/hstr-1.23.ebuild
+++ b/app-shells/hstr/hstr-1.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,7 +20,7 @@ DEPEND="
virtual/pkgconfig"
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.23-tinfo.patch" )
src_prepare() {
default
diff --git a/app-shells/hstr/hstr-1.24.ebuild b/app-shells/hstr/hstr-1.24.ebuild
index fc44e8039c0b..4e958038c0c9 100644
--- a/app-shells/hstr/hstr-1.24.ebuild
+++ b/app-shells/hstr/hstr-1.24.ebuild
@@ -20,7 +20,7 @@ DEPEND="
virtual/pkgconfig"
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.23-tinfo.patch" )
src_prepare() {
default
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index 141e5f2f692b..746fc0b3577e 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -7,7 +7,10 @@ DIST zsh-5.3.1-doc.tar.xz 3161408 BLAKE2B dc14f7b6136b73d5cfe8462fe67e20b92ee047
DIST zsh-5.3.1.tar.xz 2928832 BLAKE2B b561629f8641dac70a5b35e12333fb3b214c83ebd90d432c302e8b8e6fb1baa288ec4d32fdb7f917c2f1a845b96a6c676ab4e15a014a8b9474792cb77e2afea0 SHA512 25f723c76d2779c3cb53de2e0dbb1163ec289f76282bec49757880d0ce32bf64a001a6b40c54c290d342aa09f92319af5c597bff99de8dbd1fc895c11836f304
DIST zsh-5.4.2-doc.tar.xz 3198880 BLAKE2B 9ef3c6690251025b669a1cb46d3903d26a7407bc9fc0463c6d3678db57180b690f11302b202346a67afde16f6177fc8a597edca53bf55aaa835a5208e205b75e SHA512 5dcf561380ec46358754a0a03224152cb0db197d8a1558c6457342a6fd0ec6ea43bc3c1c1a79390a2a6034e09e0e668466962462ab14e90807170436a36f82b7
DIST zsh-5.4.2.tar.gz 4482413 BLAKE2B c3b9eb2b1458d88d8849898fa468a5e8575ac06f7859c809e741410b672a61c877027d4d5057b8c2295e6f15ce1f2fed9c0ca3eacf4024b8478b9e1d287c0378 SHA512 5eaa2ff3dc8052dfb50d2be19bfeed1856b00f7c2dc698129c95c2373a516ee61dba5b42ded390ac20b171abe352b1875f177a4dda8fdc15a4f2a05bb7a024e2
+DIST zsh-5.5-doc.tar.xz 3216400 BLAKE2B 3d07b336222b08d7deff0ded6f603a47bcdcec978e6ad9c244b25f5249e07c22768ba30e67f02c8ebf4a0a8104997d0aa8959de7e3c39a428dca0b013c56e9b1 SHA512 0bde166bc4a4b8ea7512bd9d3ede53478959cb76ded65488b9a8993734cf2a8ffedcd38254fbf6ff73a5841289cb65715579744b10748afb038c9d93a01f987b
+DIST zsh-5.5.tar.gz 4576506 BLAKE2B 4f5923d519b0c96475f4832cf0e5cabc1432e765d201c992903ead45b175d5bc76410ebe248c2bd01ad75a5b5939bc5bc58e9263bb4501f9b2c1f5b4d7755896 SHA512 aafa29e1bc29d35fb5822ad4ca5f4c64b1e4a4e3f9bff70e9e5976918fa9e7906467bd11f69291e694dfa77efa1e5433d7839fc668aa572228623f1c131c381f
EBUILD zsh-5.3.1.ebuild 5981 BLAKE2B 7bb0e3b81104e115c0ffc9ac593440b9ab61cf89cc33842a3df467ace612573c1f069a9032a8cc1d58f92f47b64900ce042b23a4273a435ab96cf0cc3ad46c1d SHA512 b1173c76320d9c615793c65fa214320f6ef02cac834233e69d242e01834012ab1b32a886666955bc49720874557cdaf14ac5734bd29c04578bc74e87526e2afa
EBUILD zsh-5.4.2-r1.ebuild 5819 BLAKE2B 1f45243236f22a943a2a2e3fd3d3b3080a96f62c20198a07c48260a5c777648678413258f4376af37697b5fdc2787d13fea1b0554722c5ec01c0053667121e09 SHA512 67330d6e88556b94bef686eff830e8cac169d472a2352ff5486d81f69b7ca3285f1502d5f38f1c8047b01d2ebfded7b166dcce3be318577e9578657f9d8c5a58
+EBUILD zsh-5.5.ebuild 5817 BLAKE2B b682d82696d9685ab2053af4acb4df5d7e9e1bd2158ad0df477966144bf0e82e8dcc95311d765a71de56679ca8d1e334769c50520f6438ab3b690154c868eba4 SHA512 c8775df0a02063b02ca59bf5a760418722af925f50b08e96ed925fa3cb72a2b856d64743906090ec29e2800f2892715c66042eebdd6125817bef1b320f210f00
EBUILD zsh-9999.ebuild 5998 BLAKE2B 265d73cf7284891a347f6ad353d6b1f71fd95b74e0b3234562dc713bbb759efb81862abc68b448338cac6ae76cb3bcfe1d9a2bf16392841f24fd63b617245204 SHA512 8476d8741eae45dd02cb03d6c633d5025aa05ebbf342d2650b21664d23447cf7ff18d15e3dca666553f0e885c33108718cc3859195e5a67bd22087a2e40b25f2
MISC metadata.xml 627 BLAKE2B 075ca50a779af22aa7664943a0ec270d99869d615d73aa65f5483d4ae30821ca535f18e8841c43f2359ae83650f32931a6f91e8b0eab63ceee7ec4754db55f3c SHA512 489307b83b15893965874824d59bf9d54a6f82aa13c62e1e7a12ada87d10b8e5d3ab63c6e1dc327b087f7403c871ce3cb766423e3513ed0c3b2304342775fbb1
diff --git a/app-shells/zsh/zsh-5.5.ebuild b/app-shells/zsh/zsh-5.5.ebuild
new file mode 100644
index 000000000000..39220778f4b1
--- /dev/null
+++ b/app-shells/zsh/zsh-5.5.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic prefix
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+else
+ KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="https://www.zsh.org/pub/${P}.tar.gz
+ doc? ( https://www.zsh.org/pub/${P}-doc.tar.xz )"
+fi
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="https://www.zsh.org/"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ !<sys-apps/baselayout-2.4.1
+"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+if [[ ${PV} == 9999* ]] ; then
+ DEPEND+=" app-text/yodl
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+fi
+
+src_prepare() {
+ if [[ ${PV} != 9999* ]]; then
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ # add openrc specific options for init.d completion
+ eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
+ fi
+
+ eapply_user
+
+ if [[ ${PV} == 9999* ]] ; then
+ sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-etcdir="${EPREFIX}"/etc/zsh
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
+ --enable-function-subdirs
+ --with-tcsetpgrp
+ $(use_enable maildir maildir-support)
+ $(use_enable pcre)
+ $(use_enable caps cap)
+ $(use_enable unicode multibyte)
+ $(use_enable gdbm )
+ )
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == 9999* ]] && use doc ; then
+ emake -C Doc everything
+ fi
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install $(usex doc "install.info" "")
+
+ insinto /etc/zsh
+ export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
+ newins "$(prefixify_ro "${FILESDIR}"/zprofile-3)" zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i {Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ docinto html
+ dodoc Doc/*.html
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/gentoo-zsh-completions and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Note that a system zprofile startup file is installed. This will override"
+ elog "PATH and possibly other variables that a user may set in ~/.zshenv."
+ elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
+ elog "or other user startup files that are sourced after the system zprofile."
+ echo
+ elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
+ elog "one method is to use a separate path-setting file that is conditionally sourced"
+ elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
+ elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
+ echo
+ elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
+ echo
+ fi
+}