summaryrefslogtreecommitdiff
path: root/app-shells/zsh-syntax-highlighting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-shells/zsh-syntax-highlighting
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-shells/zsh-syntax-highlighting')
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest4
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild2
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild42
3 files changed, 46 insertions, 2 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
index afd63a49bc94..28cf466607a8 100644
--- a/app-shells/zsh-syntax-highlighting/Manifest
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -1,3 +1,5 @@
DIST zsh-syntax-highlighting-0.7.0_beta1.tar.gz 130063 BLAKE2B cf0f6319af22b47cb8a280de682a69b0479dc59033be5ce84840507b77dd2df0441b8d260af55bccb303c87d7f5a7e4cc6db9f46860aee040b4b8115c76f5e07 SHA512 1692015aad58103c752e2dd4161ea87f26aaa09d34eb2faec1f651fea1d9bfad29226455468017160a5393a87c1f7ed0514b09b0802b1810377beef72bfa6c87
-EBUILD zsh-syntax-highlighting-0.7.0_beta1.ebuild 1001 BLAKE2B c57f7c1481dfddccf9757faf2956563382bd43b32faceb7edaa47feb228c331064a664c4177e9cfac0066cbecef42b5b43ffc7fd9bdd7bb9d0ad4a30e4c1462b SHA512 37a1966be8434416fbd1a3a992a0cc3b0dc1a49293763b63a9f009060372208275f44c70304ecf707f002248bb5a41541680089a782a92f86506111074a9aace
+DIST zsh-syntax-highlighting-0.7.1.tar.gz 133554 BLAKE2B cd55a0ad69670b25edc4bfa78ad76d1e2ef501deeca3e93adbef0aca305896722b4906d7717be3ad61bc0cf6b6496e217626406e5ff4168ece4b75bffd94bbf0 SHA512 e7e86b88cdac9b9ed5f973823ba8efff99dd720b9ed929f765f9f9266b9d6e147274f5957ceb630d51a660e396fc22e97f10cfbc5cdde941b907f3773bb1ea2b
+EBUILD zsh-syntax-highlighting-0.7.0_beta1.ebuild 999 BLAKE2B 5912b92c1b31242b364cea1fcb91b11aafa8753be046ceb2291bb10735f35a63470f6bc49b920375db3528b696c6a8cdd6bc5450bfb44615d0ad797034537d4c SHA512 fd1b4b6083ee119afd5104a91995e4227e393bd399989751e996435994d42299194ebbcac500bae6dfe13c6ca4c3f36586c4b2dc1361e16c402f722c7a123a55
+EBUILD zsh-syntax-highlighting-0.7.1.ebuild 1001 BLAKE2B c57f7c1481dfddccf9757faf2956563382bd43b32faceb7edaa47feb228c331064a664c4177e9cfac0066cbecef42b5b43ffc7fd9bdd7bb9d0ad4a30e4c1462b SHA512 37a1966be8434416fbd1a3a992a0cc3b0dc1a49293763b63a9f009060372208275f44c70304ecf707f002248bb5a41541680089a782a92f86506111074a9aace
MISC metadata.xml 243 BLAKE2B f7576f14be2c0aa21ca2c7147133e4a4132d6559cca1519745dd2f4ea912b3856950c7645e13d2317f38c80ba93b13d47370260920241a5ab60a4eae59f2cf33 SHA512 0dc1f228861badffd9c4175af734b72435dc7c60d369a3d9ff946c5b98b3f2f49af7d433f7ec5fc2afee7015b8f75259e8debe150b1bcffa0cb66425bed10d8d
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild
index 8ca8ffb2e2b8..0ba4e019c3f3 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild
@@ -11,7 +11,7 @@ if [[ -z ${PV%%*9999} ]]; then
else
MY_PV=$(ver_rs 3 -)
SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild
new file mode 100644
index 000000000000..8ca8ffb2e2b8
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+if [[ -z ${PV%%*9999} ]]; then
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+else
+ MY_PV=$(ver_rs 3 -)
+ SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc"
+
+src_prepare() {
+ sed -i -e 's/COPYING.md//' Makefile || die
+ default
+}
+
+src_install() {
+ emake \
+ SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+ readme.gentoo_create_doc
+}