summaryrefslogtreecommitdiff
path: root/app-shells/yash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
commitc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (patch)
tree3ed89f0ec34cf85a0c06c027a6889e7890e08db6 /app-shells/yash
parent8965d348ad07c326c8e17e3137c151bcc98b0a53 (diff)
gentoo auto-resync : 06:09:2022 - 22:33:57
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest2
-rw-r--r--app-shells/yash/yash-2.53.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 56e263832b90..8f28fef657e3 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,3 +1,5 @@
DIST yash-2.52.tar.xz 755016 BLAKE2B 44c26d310e9bd50a6f381adefedcdf9bcb49998860a8a67e300d31d5a8615d7346e06e7c4ca5e098d7232a0acc112daa2230572939f665db982f187ccd741778 SHA512 1024ff7e3cce6e64cbc0bd5c0d04a9863d0d51013baf07723d09562b156d05dbfe1fc2df5b736cdec5f562c56ad634f865554a1fe5aeeed91ec0d9276667f02a
+DIST yash-2.53.tar.xz 755956 BLAKE2B 191bdc6fcda7c3043d3db53b70fcdba86fab740df2aaf1249380c4679f51ec61b9a36c51a7982c516f51f8a2605729d7242d81f738523edfc07f21be1a06ff45 SHA512 9bc6dcc9864fbba6200b76dad50b9eb1620b578fceaea5d1dd34e2efda379be0e4255d56e49c9595dc184ddf45951418e87a88dc6507d41cc4220f38b7044994
EBUILD yash-2.52.ebuild 803 BLAKE2B 67bd77fd81ff45f0f1d14cf5f4dc81ca33dc228cc5ac8e78fc4044df8d89f1bb79a5325e666481dbc5bde31fcf194a90413e9e2d35a09f7146c5b12f027403a8 SHA512 2554bb0b62d3e9c52c01d46be3d77bc02315d1113847d49cbcf5ffd9f27a329eca36217c268ba7697d39944b476b27ee3804489e8a91723d9f2f303d5c723581
+EBUILD yash-2.53.ebuild 805 BLAKE2B f160b7725426709f3fb0b7a96399c8941df08648b723ef9320c2bed4279269ed4e9baa4c5939895496cb06918d6693fe27d54145ae16f78fe07a549858761cbb SHA512 9387f43018e747d3f818ff26375a651f499f4b332c321d968c9fd57476727121afbf180e1a7bd32d18316ee29b30168a05e424a5525544639f0625028f3bbf90
MISC metadata.xml 1065 BLAKE2B ab9ec0ac6fbf2666a7e987b6a4cfd62f8520f541eb0d900602a782f895757d85ab07f61ca60cfab3cd6042a4e24cb311eb17a4fc163c2652f3c9b7ec4f3cafa2 SHA512 1bf5664d53623cc41a2509662889fe967b62068b27d36f30152fb59de29b46af03ea5baa1a778b2dca6232ffe3d564db37a6432f5f8cdc585a8c88e87fc9ab9f
diff --git a/app-shells/yash/yash-2.53.ebuild b/app-shells/yash/yash-2.53.ebuild
new file mode 100644
index 000000000000..fbee726df1c7
--- /dev/null
+++ b/app-shells/yash/yash-2.53.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/77664/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}