summaryrefslogtreecommitdiff
path: root/app-shells/yash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/yash
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest3
-rw-r--r--app-shells/yash/metadata.xml26
-rw-r--r--app-shells/yash/yash-2.47.ebuild33
3 files changed, 62 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
new file mode 100644
index 000000000000..00594b1d0787
--- /dev/null
+++ b/app-shells/yash/Manifest
@@ -0,0 +1,3 @@
+DIST yash-2.47.tar.gz 1161675 BLAKE2B 8491d5f977b9e23071098016443e8384bc584b8b1160e84b725a2965d032d8b8f5a7ac8b16b1a1e62d808b0543650e0bc42ddc52806c5475a7ca9e26640e84aa SHA512 c9607990a1cf947f9cf294f818d9c6de314dca92a9f106dc65e8d0fdeb6ac91b21a394c711c4b8aabae33b60fc70b72dc9483b6ac48d4e3be3019501ebc26332
+EBUILD yash-2.47.ebuild 733 BLAKE2B 688783dea182e8cb56cd1aa110f83bbab06bf6c7904d73b3a679404a499bce145f62d691b826ab7974ac8f5fa1fba4c76b28821f67ce4dfdc104f9ca6df3cbf5 SHA512 d08d976a08aabe64e96daf90c7e75aea0fb89dab160aa3d2a1922a260e1d91e7a7f672da508abe56c4a02be2bd16707065d41bcf8f3a1bcd426c875439ba5312
+MISC metadata.xml 1043 BLAKE2B a83b4a65aace09de65f4c1f44b99711171ffe1d5abc453f0c616fc02d0dfb63828ca7dc7ca431641c6c87d4aab15c5160802ee534de055e0f53bc0350a4110d5 SHA512 004f1faa56032de6e2f37af8199f165c4394a4f7a3c2e2eebd79254a5155bf429e0e0d1e97e7b025037d7a3fbcf91d14b67e37dbe0313fe1ca38a2a7d56ec9f4
diff --git a/app-shells/yash/metadata.xml b/app-shells/yash/metadata.xml
new file mode 100644
index 000000000000..106f4c845b23
--- /dev/null
+++ b/app-shells/yash/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Yash, yet another shell, is a POSIX-compliant command line shell
+ written in C99 (ISO/IEC 9899:1999). Yash is intended to be the most
+ POSIX-compliant shell in the world while supporting features for daily
+ interactive and scripting use. Notable features are:
+
+ * Global aliases
+ * Arrays
+ * Socket redirection, pipeline redirection, and process redirection
+ * Brace expansion and extended globbing
+ * Fractional numbers in arithmetic expansion
+ * Prompt command and command-not-found handler
+ * Command line completion with predefined completion scripts for more than 100 commands
+ * Command line prediction based on command history
+ </longdescription>
+ <upstream>
+ <remote-id type="github">magicant/yash</remote-id>
+ <remote-id type="sourceforge-jp">yash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/yash/yash-2.47.ebuild b/app-shells/yash/yash-2.47.ebuild
new file mode 100644
index 000000000000..ae2eee4bca5b
--- /dev/null
+++ b/app-shells/yash/yash-2.47.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PLOCALES="en ja"
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/69353/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}