summaryrefslogtreecommitdiff
path: root/app-shells/ugit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /app-shells/ugit
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'app-shells/ugit')
-rw-r--r--app-shells/ugit/Manifest4
-rw-r--r--app-shells/ugit/metadata.xml2
-rw-r--r--app-shells/ugit/ugit-0.4.5.ebuild36
3 files changed, 40 insertions, 2 deletions
diff --git a/app-shells/ugit/Manifest b/app-shells/ugit/Manifest
index 81ac7eb0d9fe..573ef7440e08 100644
--- a/app-shells/ugit/Manifest
+++ b/app-shells/ugit/Manifest
@@ -1,3 +1,5 @@
DIST ugit-0.4.4.tar.gz 149708 BLAKE2B 5cc59d36c0647f472cbb4787cca400684d0dcb1ead476a733aa3fed49b5bf4392d33c206aae912f6e67af6bbe8732f9bfd6870b6c0a6c14b6cebcc2cadb0a2a1 SHA512 a01ba28186c68671817e71b0cc33f191cc22abea9c8ceedc881de573bfdc8c13c81ec4fb03e964be2e39b84a32dfeee61c6d11e7595b8e8fa50912b117f41e77
+DIST ugit-0.4.5.tar.gz 165899 BLAKE2B 906fa38c3d10a68368ec9e8a3a395e68c73b0bab8d4a9e75043266f84604dbda1501823f2782ee550319d1f5064a36bac40299729c101509b72681bd7566553a SHA512 a3008f651ab3bd418631b35eeba32bd4cfa2fbcf050360032d94fe84082e59e8a26fe044c473b61f0cf6f05cdecedf03c7df050f9062b266a3a1c0140c05a224
EBUILD ugit-0.4.4.ebuild 778 BLAKE2B 8824b12bddfe50bc3d27c5bc71ff2f5bc9efcd6dd42a9a55846233166969e3d1a63879bb9cafdb02a60881e27ac4f303a7bcdf1df0ce3dbd7c5faf9abb1de057 SHA512 926701754d39d653f57d2848094cb26a5960bb55e8cffddb573e8ab76edc8d11bd56607397a2f98bf3089960dd3e0bc0f164b805cf6a81e47562ad0bd79c0111
-MISC metadata.xml 423 BLAKE2B 621438909ee7b04cb57711f68a88cad10e7031dbee489e8b3209e4786fe5ac614d2df5942d5382be3ddffd7eeb5afc616bfb71b3c6f2f36c7992e4009f91580b SHA512 add4e472e8a873958b5967966a4b642a8dccbe4205e3e23f19361eb7cf3133e997a12291128605c2e3f2d95d6588df76c2c8d72160bbb58f549c0d47c4fb1d88
+EBUILD ugit-0.4.5.ebuild 779 BLAKE2B 69d9aab5a0b9d144d471608c3bd3b03117d99343b7e55881e3f97c4fa65f8aa5a62e67cc9b87a1f77971e195f970e412619fd61dd4bd467fd5886773fdf52f66 SHA512 ccbaed205d1b74fb3b0b57c66f775e536ab3a594fc2b3a6450a7f4fa1ad774e12a14aa857aa90e546f7bc3814e3e792418c61960ab9eadbe2b8ced67743c8cfd
+MISC metadata.xml 423 BLAKE2B 0752c36b9d124e457b8c49bec1d9d5d9517c92cc8643eb6f8a9b4b5e66698c29b3128d5e07d1713f8478b8e3f3c2b38de84912a083017d8ce012ceeb07022f18 SHA512 741e35e6e81797641cbf9a3ad9308970f0c1ab2fe557a6b31546fe578141dd0f9a5cdded02a3b70eef9623d19274dd05d89737b5272e7eaa7677a5a042fc272b
diff --git a/app-shells/ugit/metadata.xml b/app-shells/ugit/metadata.xml
index 16e9adce3978..3e0ec7914a55 100644
--- a/app-shells/ugit/metadata.xml
+++ b/app-shells/ugit/metadata.xml
@@ -7,7 +7,7 @@
<name>Gentoo Dotnet Project</name>
</maintainer>
<upstream>
- <bugs-to>https://gitlab.com/StartAutomating/ugit/issues/</bugs-to>
+ <bugs-to>https://github.com/StartAutomating/ugit/issues/</bugs-to>
<remote-id type="github">StartAutomating/ugit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-shells/ugit/ugit-0.4.5.ebuild b/app-shells/ugit/ugit-0.4.5.ebuild
new file mode 100644
index 000000000000..f321df3b91f8
--- /dev/null
+++ b/app-shells/ugit/ugit-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell wrapper for git, automate repos and output git as objects"
+HOMEPAGE="https://ugit.start-automating.com/
+ https://github.com/StartAutomating/ugit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/pwsh:*
+"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Commands Extensions Types en-us
+
+ dodoc *.md
+}