summaryrefslogtreecommitdiff
path: root/app-shells/tmux-bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/tmux-bash-completion
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/tmux-bash-completion')
-rw-r--r--app-shells/tmux-bash-completion/Manifest2
-rw-r--r--app-shells/tmux-bash-completion/metadata.xml15
-rw-r--r--app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/tmux-bash-completion/Manifest b/app-shells/tmux-bash-completion/Manifest
new file mode 100644
index 000000000000..f156b3096e3f
--- /dev/null
+++ b/app-shells/tmux-bash-completion/Manifest
@@ -0,0 +1,2 @@
+EBUILD tmux-bash-completion-9999.ebuild 520 BLAKE2B 9ac470c42e2e56634983c32ccfb7aac0ccaf6d0a747989e9dec2600e3314f6fabc5cb18e9c9fdee7306d3b1df97576e8c9b0af8bce282ce9f89a05bfe4394be4 SHA512 dc4b6d6be23e096d7603b3e610d2d4191a25ba444c7ac09c5a96bf1d93b86a97e3cfb4c1958a825a959f9abff2eb963719b19bec8ffc540c8b86c09f3c2273b2
+MISC metadata.xml 466 BLAKE2B 2c4d6dfb4316cb3e54c52d21fd4103ce3dd027365784eeb4c7518d72100edb1e082dc4453b35d20deef5367e688a41205f80571d7dc972c3408e153b9f1252d4 SHA512 43cc836a286e1a0af0dd8a0a5762ea88368c1cf601795febb9134f4ab9d257b3ebcdc5d62d7e1651c776cd94437a7dfdc082c2bfd4b5ff82227f3236738b6c27
diff --git a/app-shells/tmux-bash-completion/metadata.xml b/app-shells/tmux-bash-completion/metadata.xml
new file mode 100644
index 000000000000..1f6ba86c16f2
--- /dev/null
+++ b/app-shells/tmux-bash-completion/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>imomaliev@github.com</email>
+ <name>Sardorbek Imomaliev</name>
+ </maintainer>
+ <remote-id type="github">imomaliev/tmux-bash-completion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
new file mode 100644
index 000000000000..da4498863deb
--- /dev/null
+++ b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="bash-completion scripts for tmux"
+HOMEPAGE="https://github.com/imomaliev/tmux-bash-completion"
+EGIT_REPO_URI="https://github.com/imomaliev/tmux-bash-completion.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=app-misc/tmux-2.2
+ app-shells/bash-completion
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ dobashcomp "${S}"/completions/tmux
+}