summaryrefslogtreecommitdiff
path: root/app-shells/thefuck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 11:19:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 11:19:44 +0100
commitc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (patch)
tree354e4022d98ceadbdf02f98879cc8b1feb4d61b1 /app-shells/thefuck
parent149480f9f5548b5a0fdb457abd473f8d10f60f51 (diff)
gentoo auto-resync : 01:05:2023 - 11:19:44
Diffstat (limited to 'app-shells/thefuck')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.32-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index 34455b90d590..a84e5c1dce24 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1,3 +1,4 @@
DIST thefuck-3.32.tar.gz 1234795 BLAKE2B f62aca1601b2cec4cc14dc63f6d7e7fffc8ab0e1cf88e44c3170ec6744998e97e97813e9dc6aaccc0a850b0a15f958483da24bcf1d176e43bad1b2272272e7a0 SHA512 961b9b6dc374cc0b854698455f688cf110adb21cfebd4cb645eb5f1ce11c14de6699bb4d40de86a5f9461273cbfc2eea318a9d437f803dc578dd431966cf26c1
+EBUILD thefuck-3.32-r1.ebuild 1154 BLAKE2B e4994187ccafa9292db7859e3d944bbba7b1546da96ebdccc179055e048e9ebf92fbf6f058b9c72b1f4a85f2ec389e8a07c00d6b2c5b792fbb5951895f318cf7 SHA512 79c74b5caabcb1c9c37ed45ff9ccb0bdbf480b5d41ad831126238295691f7bae4ae51c5efb6c0d83be4eed9b819fe9686c0ac6009ccae8ecc83a268e379dc16c
EBUILD thefuck-3.32.ebuild 880 BLAKE2B 33d3844291aff718733891764bebe53b61a4fcf8b88676a4d8e2728aac6976746765668e94bb1243a89d8f0cf37eb8b11a04baa337bc555d783e725d9da88416 SHA512 a5ec9fe2764887c580e5d53a93ca2ca0e1f02102ac60e2bccdf0917db0111e9735332bc5ddcd88832138b84462c522d5db4e4dda68e0df2e41d28590480d9e99
MISC metadata.xml 269 BLAKE2B 19b3e31874e41daeee0fcc465075c0519eb2e56df2eb93a93b48e1041459802d3e0312fc7298ed25742f7058dd0e24982c1da267a1cf65fdd9fbaced7d206e9c SHA512 a5cc8b5aa63bca75b9e84676d513003707cbbfc2ce2c51a989896032e7cc134b3759056fc9d4262545c442307267edd801dad16c392d48aa7bfed2a894f14733
diff --git a/app-shells/thefuck/thefuck-3.32-r1.ebuild b/app-shells/thefuck/thefuck-3.32-r1.ebuild
new file mode 100644
index 000000000000..bfee9daa1a8c
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.32-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing tests because of trying to access portage's home dir
+ tests/test_conf.py
+ tests/entrypoints/test_not_configured.py
+ tests/test_utils.py::test_get_all_executables_exclude_paths
+ tests/test_utils.py::TestCache
+)
+
+python_prepare_all() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_python_prepare_all
+}