summaryrefslogtreecommitdiff
path: root/app-shells/thefuck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/thefuck
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/thefuck')
-rw-r--r--app-shells/thefuck/Manifest3
-rw-r--r--app-shells/thefuck/metadata.xml15
-rw-r--r--app-shells/thefuck/thefuck-3.27.ebuild41
3 files changed, 59 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
new file mode 100644
index 000000000000..5ce61e2a6f36
--- /dev/null
+++ b/app-shells/thefuck/Manifest
@@ -0,0 +1,3 @@
+DIST thefuck-3.27.tar.gz 1367120 BLAKE2B a840ac3e8f6807df632948e2fe2789a47bdcfececfd4a9bb0f1836bbaa641501e13c559221b9a2f25bbd93505c8b03db102636e480ece116a42c46f341d5cd35 SHA512 766c589f0e99a9773e74094e91c6a74d00e5be8b7241680ad664ecc3f549b597416bc7a4d289f399ed3a0d9ccad629ed78bb983edc809664c303c687ea1eec1a
+EBUILD thefuck-3.27.ebuild 956 BLAKE2B e75778707fb78994849b97f7f76c561795815583362b86b605ab78c39315916b9eab7610e9f1d2cd2681a5615cfae7ccf8e9602a32fea7d8536e79fc9e7306d5 SHA512 323bfdd7279ef3a4bf7660d74f9c03bdef4aceb011d442c35ecc7f779c9c14bb5bf1ee4d0f518740b21932ddb4de3d4d8146de18eca6d73eca955059b2a742ab
+MISC metadata.xml 443 BLAKE2B e698b6282592adbd65ea14725b58f32ac24ae0549e6b937b26084d043bcb74204c89f409ae32af0078ac073765a69e5f585e4ad1225a01d39defc1a54ff86798 SHA512 809474eff24118e6ae74bcefac2cd653cb9aa04a06fbe59e430bc291e2fc7ee87d0463967d1c1382ea8b69853c455f680a858d837b68ea8206a66739903b1452
diff --git a/app-shells/thefuck/metadata.xml b/app-shells/thefuck/metadata.xml
new file mode 100644
index 000000000000..e02f8f7384b6
--- /dev/null
+++ b/app-shells/thefuck/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>holgersson@posteo.de</email>
+ <name>Nils Freydank</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nvbn/thefuck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/thefuck/thefuck-3.27.ebuild b/app-shells/thefuck/thefuck-3.27.ebuild
new file mode 100644
index 000000000000..9216446f6ddc
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.27.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die
+}