summaryrefslogtreecommitdiff
path: root/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/squirrelsh/squirrelsh-1.2.7.ebuild')
-rw-r--r--app-shells/squirrelsh/squirrelsh-1.2.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild b/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
new file mode 100644
index 000000000000..9e5aaceff7b0
--- /dev/null
+++ b/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Cross-platform object-oriented scripting shell using the squirrel language"
+HOMEPAGE="http://squirrelsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-rename-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-no-strip.patch
+ epatch "${FILESDIR}"/${PN}-fix-in_LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-remove-forced-abi.patch
+ epatch "${FILESDIR}"/${PN}-no-docs.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
+}
+
+src_configure() {
+ #This package uses a custom written configure script
+ ./configure --prefix="${D}"/usr \
+ --with-cc="$(tc-getCC)" \
+ --with-cpp="$(tc-getCXX)" \
+ --with-linker="$(tc-getCXX)" \
+ --libdir=/usr/"$(get_libdir)" \
+ --with-pcre="system" \
+ --with-squirrel="local" \
+ --with-mime=no || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman doc/${PN}.1
+ dodoc HISTORY INSTALL README
+ use doc && dodoc doc/*.pdf
+}