summaryrefslogtreecommitdiff
path: root/app-shells/smrsh/smrsh-8.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/smrsh/smrsh-8.15.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/smrsh/smrsh-8.15.2.ebuild')
-rw-r--r--app-shells/smrsh/smrsh-8.15.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-shells/smrsh/smrsh-8.15.2.ebuild b/app-shells/smrsh/smrsh-8.15.2.ebuild
new file mode 100644
index 000000000000..c825f0f179de
--- /dev/null
+++ b/app-shells/smrsh/smrsh-8.15.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Sendmail restricted shell, for use with MTAs other than Sendmail"
+HOMEPAGE="http://www.sendmail.org/"
+SRC_URI="ftp://ftp.fu-berlin.de/unix/mail/sendmail/sendmail.${PV}.tar.gz"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!mail-mta/sendmail"
+DEPEND="${RDEPEND}
+ sys-devel/m4
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/sendmail-${PV}"
+
+src_prepare() {
+ cd "${S}/${PN}"
+ sed -e "s:/usr/libexec:/usr/sbin:g" \
+ -e "s:/usr/adm/sm.bin:/var/lib/smrsh:g" \
+ -i README -i smrsh.8 || die "sed failed"
+
+ sed -e "s:@@confCCOPTS@@:${CFLAGS}:" \
+ -e "s:@@confLDOPTS@@:${LDFLAGS}:" \
+ -e "s:@@confCC@@:$(tc-getCC):" "${FILESDIR}/site.config.m4" \
+ > "${S}/devtools/Site/site.config.m4" || die "sed failed"
+}
+
+src_compile() {
+ cd "${S}/${PN}"
+ /bin/sh Build
+}
+
+src_install() {
+ dosbin "${S}/obj.$(uname -s).$(uname -r).$(arch)/${PN}/${PN}" || die
+
+ cd "${S}/${PN}" || die
+ doman "${PN}.8" || die
+ dodoc README || die
+
+ keepdir "/var/lib/${PN}"
+}
+
+pkg_postinst() {
+ elog "smrsh is compiled to look for programs in /var/lib/smrsh."
+ echo
+}