summaryrefslogtreecommitdiff
path: root/app-shells/sash/sash-3.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-shells/sash/sash-3.8.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/sash/sash-3.8.ebuild')
-rw-r--r--app-shells/sash/sash-3.8.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
deleted file mode 100644
index 6c2ee580ce04..000000000000
--- a/app-shells/sash/sash-3.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A small (static) UNIX Shell"
-HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
-SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="static"
-
-DEPEND="
- static? ( sys-libs/zlib[static-libs] )
- !static? ( >=sys-libs/zlib-1.2.3 )"
-RDEPEND="!static? ( ${DEPEND} )"
-
-src_prepare() {
- epatch "${FILESDIR}"/sash-3.7-builtin.patch
-
- sed \
- -e "s:-O3:${CFLAGS}:" \
- -e '/strip/d' \
- -i Makefile || die
- sed \
- -e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
- -i cmd_chattr.c || die
-}
-
-src_compile() {
- use static && append-ldflags -static
-
- emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
-}
-
-src_install() {
- into /
- dobin sash
- doman sash.1
- dodoc README
-}