summaryrefslogtreecommitdiff
path: root/app-shells/rush
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /app-shells/rush
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'app-shells/rush')
-rw-r--r--app-shells/rush/Manifest3
-rw-r--r--app-shells/rush/metadata.xml8
-rw-r--r--app-shells/rush/rush-2.0.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/app-shells/rush/Manifest b/app-shells/rush/Manifest
new file mode 100644
index 000000000000..3f8041899752
--- /dev/null
+++ b/app-shells/rush/Manifest
@@ -0,0 +1,3 @@
+DIST rush-2.0.tar.xz 810096 BLAKE2B 793f341910cfa5e1560928ea96234ebcd5185e00450c81fd03e67598227973248ebe2dd12fecaba135fcf991d830e44d2e8b273ff251d1f9b8038df2575ae3cd SHA512 7087962d0489e2cdac903abf193e7b1306ae8f76eae7f722f105a70a14aae3d72627de230edd104da34ea31aa07cdc8024eff33a9c70b987a2111435fe2a684e
+EBUILD rush-2.0.ebuild 530 BLAKE2B 3aaf60da7cc41d208c54f5c8bcdf7c4d43296d3fed2523720ab9032c2caca68bef91f03171101fc1df93f4828b0583a04deb7038c3bbd41564c96a0f281c84a5 SHA512 5822d08860a3dcc62345a35542505cbd2ef280fc60487c60fc6d3f79be693469cdf3ce45264a20814d8aed91e09e2eec7db3fc46e16b44be26c111bb8761b877
+MISC metadata.xml 257 BLAKE2B 35c1b06807230338ceb9de70f79760d55e93dcdba508da3c663e785ab3966781edc2098abd8df084b2ecabbf40ff8e8e4a0d0a6e131daf648ff58e101cf27587 SHA512 ff078cacb115b8f3624b45d883d8ed72701e3d2fccae06c04c633eb60821b23681cc151e00689d1b6035c94570535e7ac0de51a55dae99f606886164883185ea
diff --git a/app-shells/rush/metadata.xml b/app-shells/rush/metadata.xml
new file mode 100644
index 000000000000..c7be278b6458
--- /dev/null
+++ b/app-shells/rush/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rush/rush-2.0.ebuild b/app-shells/rush/rush-2.0.ebuild
new file mode 100644
index 000000000000..cabf20f3885d
--- /dev/null
+++ b/app-shells/rush/rush-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+# Testsuite doesn't like our sandbox (bug #689554)
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}