summaryrefslogtreecommitdiff
path: root/app-shells/rush/rush-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /app-shells/rush/rush-2.1.ebuild
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'app-shells/rush/rush-2.1.ebuild')
-rw-r--r--app-shells/rush/rush-2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/rush/rush-2.1.ebuild b/app-shells/rush/rush-2.1.ebuild
new file mode 100644
index 000000000000..cabf20f3885d
--- /dev/null
+++ b/app-shells/rush/rush-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+# Testsuite doesn't like our sandbox (bug #689554)
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}