summaryrefslogtreecommitdiff
path: root/app-shells/rc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-shells/rc
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-shells/rc')
-rw-r--r--app-shells/rc/Manifest1
-rw-r--r--app-shells/rc/rc-1.7.4-r2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-shells/rc/Manifest b/app-shells/rc/Manifest
index 337e30900206..54188ad44431 100644
--- a/app-shells/rc/Manifest
+++ b/app-shells/rc/Manifest
@@ -1,3 +1,4 @@
DIST rc-1.7.4.tar.gz 215206 BLAKE2B df01f618cd4d3c5bbf155768ada49c20fe7916e2b999ae13d08487b00c4565c3c4d1d45d16dddef70fe58cf7c405d293832b31dc8a66d8b36b2503675b260db1 SHA512 49e124207b5370b88b8fba0376dda33451451a58bfb85fabfc06ae59eb88fedf38d7aeaaf292e4f380e2c00efc8301ba68d12180923186d1c53ef94f78f7e435
EBUILD rc-1.7.4-r1.ebuild 890 BLAKE2B 10ade84c2dd5f77a63450c4ab9be6d30344162ac32a45e97cfc84403d774d88442768b2df2af138249f7c6f25d2724b36b41e145d376fc5be973cf11f7eb716a SHA512 9b915a58614610f4326d8359772f7f536349e6844a823976b8256affbdbb4f3cc61f0d28d7a14319a1cff2c5ffebbe4fe6e08e02ddfddc0b60a5b98ac35b116b
+EBUILD rc-1.7.4-r2.ebuild 918 BLAKE2B c03a0faded61c2fbdbf5863ea3115a88a9346aa370e4ff81580db7594b3ebd522cd3003907fb17853126338f16bfd1806eca6a000d631d5b5a2202acfcbb42d0 SHA512 d99c536c0a2011a79b1ec27a42dc2f7ca3391f38aaeb52d0d27b1af58d3a9674d9f2cb749fe790ca1c08f3a90002cf2b77506e5d1799cf2ccb291f1400b78253
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-shells/rc/rc-1.7.4-r2.ebuild b/app-shells/rc/rc-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a38be60805e8
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="sys-libs/ncurses:=
+ readline? ( sys-libs/readline:= )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=edit"
+
+ econf "${myconf}"
+}
+
+src_install() {
+ into /usr
+ newbin "${PN}" "${PN}sh"
+ newman "${PN}.1" "${PN}sh.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! grep -q '^/usr/bin/rcsh$' "${EROOT}"/etc/shells ; then
+ ebegin "Updating /etc/shells"
+ echo "/usr/bin/rcsh" >> "${EROOT}"/etc/shells
+ eend $?
+ fi
+}