summaryrefslogtreecommitdiff
path: root/app-shells/quoter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/quoter
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/quoter')
-rw-r--r--app-shells/quoter/Manifest3
-rw-r--r--app-shells/quoter/metadata.xml22
-rw-r--r--app-shells/quoter/quoter-3.0_p2-r1.ebuild25
3 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/quoter/Manifest b/app-shells/quoter/Manifest
new file mode 100644
index 000000000000..962eec434b27
--- /dev/null
+++ b/app-shells/quoter/Manifest
@@ -0,0 +1,3 @@
+DIST quoter-3.0_p2.tar.gz 10691 BLAKE2B 2fb196977c5c16654813e6077c148577e4629da25fb1aaf2131c19e33fbfbc670ad4d9af87611405f0b45a1365bc7b4b3f1b8cad47573ffae4939cc0329d50a4 SHA512 23d77105fa05d79a7d0bcaa3f6aead25b7cb3b6f459d2740314616da587e03cd3e6b0b1e8af8f79904309bbe76603db848d42996ed7ae5ef779e27184a434fb5
+EBUILD quoter-3.0_p2-r1.ebuild 793 BLAKE2B 00cf5370c37448172e8c4ae0b1eb9850a906577ffffb6286b5697646648ce2d77d9b4d9688524d0b137e311858ce4df071dadae5dc5c7ba7be9023c81b62c15c SHA512 bc255d51e52f564a5d325d590da492c7f1bb3c154f99ca592386902adddb67b5cf2e5169300b3ea57e6fef52e0c5ed6bb4dcb543af2cb432b3cb53d871196f66
+MISC metadata.xml 696 BLAKE2B dd6a68084f8a93ba5cd9d358c260bbf93bc8515c6610ae8d73004b53b7173e47103d9189123515e607826f1b8226fe909a17442ae3c89832a21f2686ed13c8c0 SHA512 30cfae6f7af84bdde697740d3d03d27ddaaed81cd631a9fb8e2b12f11e8acb0de2680437b5679def2c8e3bb09bd69c26651e89d4f67e46b2e72e6e8274cee358
diff --git a/app-shells/quoter/metadata.xml b/app-shells/quoter/metadata.xml
new file mode 100644
index 000000000000..531820332509
--- /dev/null
+++ b/app-shells/quoter/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>Upstream developer, CC on bugs, do not copy ebuilds
+ from his overlay</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/quoter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/quoter/quoter-3.0_p2-r1.ebuild b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
new file mode 100644
index 000000000000..4c1901dae04b
--- /dev/null
+++ b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2016-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ rm -f "${ED}"/usr/bin/quoter_pipe.sh || die
+ insinto /usr/share/${PN}
+ doins bin/quoter_pipe.sh
+}