summaryrefslogtreecommitdiff
path: root/app-shells/quoter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-shells/quoter
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-shells/quoter')
-rw-r--r--app-shells/quoter/Manifest2
-rw-r--r--app-shells/quoter/quoter-4.2.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/app-shells/quoter/Manifest b/app-shells/quoter/Manifest
index e6e3e5fc1ac4..d0bb576cfd97 100644
--- a/app-shells/quoter/Manifest
+++ b/app-shells/quoter/Manifest
@@ -1,3 +1,5 @@
DIST quoter-3.0_p2.tar.gz 10691 BLAKE2B 2fb196977c5c16654813e6077c148577e4629da25fb1aaf2131c19e33fbfbc670ad4d9af87611405f0b45a1365bc7b4b3f1b8cad47573ffae4939cc0329d50a4 SHA512 23d77105fa05d79a7d0bcaa3f6aead25b7cb3b6f459d2740314616da587e03cd3e6b0b1e8af8f79904309bbe76603db848d42996ed7ae5ef779e27184a434fb5
+DIST quoter-4.2.tar.gz 11128 BLAKE2B 6b13a8eabae57c50c12dcbf9a65e28990ee6d74ee2c45c4a6127f5ed98c2ae029fd5d00f82444c46ab6a21057c6279e9f3d19c432f921d04ca3bf3eaa9507cb0 SHA512 0080ae6d5f5308b9e2f9e414619049f10246c221a9524f9f0dc0d329af3592694ae9d6ef6a086615b895c5f6598fbed7ec7164b5a847d11108fbe3687316c02d
EBUILD quoter-3.0_p2-r1.ebuild 759 BLAKE2B 834746ed908c95f45f09c08e4a93a1e0a054b606628f79a10a48be823660cc73ff2f4157d51438ffb2ac92f6e0fb48559db69025832a994029448b6e6816973d SHA512 8da8ce840b416bfa2ce03e653e33d0ca06dec49b6a43016ef69a164c95b1ac54650e6e4b88432e888536b8e2a2b27c2620dd4dfd5219f028460e7b979051c447
+EBUILD quoter-4.2.ebuild 768 BLAKE2B d8824eb44ad83bdcc0630f983f7b2db41af9769c950effd75544dfa492782abe4f3ed02e8ccf7acf5cff69ca4b506c531bcf0391d399fd3fbcba73c7aa8306cb SHA512 0d71a65f004e0de0f8d4d7d614417d80eb9daae4c3fbcdd6fca78dc19a8cd75ef73e915de5dd5c41670accbe7d74fe299b5d5b57096ec237d0a076d1c050ee13
MISC metadata.xml 700 BLAKE2B 6dc4829d807dbc1ed2a511689c3fbe3ceb322236525770a55c86ddb3956bf974a58dedc1c0a7ff74b936e76c8729e1e2463ee0a51ac9e51ac89472a28dcee63f SHA512 c3cda33bc2aedb177d4734ad02cb2dbe0b2d52bc73406ee5277b7db57ff73c047cc174514c516ba3486c1ad5d93d414f77d2655c9cbff9de1820effac312a284
diff --git a/app-shells/quoter/quoter-4.2.ebuild b/app-shells/quoter/quoter-4.2.ebuild
new file mode 100644
index 000000000000..71913b702e01
--- /dev/null
+++ b/app-shells/quoter/quoter-4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2016-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ rm -f "${ED}"/usr/bin/quoter_pipe.sh || die
+ insinto /usr/share/${PN}
+ doins bin/quoter_pipe.sh
+}