summaryrefslogtreecommitdiff
path: root/app-shells/psh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/psh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/psh')
-rw-r--r--app-shells/psh/Manifest5
-rw-r--r--app-shells/psh/files/psh-1.8.1-r3-array-ref-deprecated.patch37
-rw-r--r--app-shells/psh/files/psh-1.8.1-r3-defined-array.patch11
-rw-r--r--app-shells/psh/metadata.xml11
-rw-r--r--app-shells/psh/psh-1.8.1-r3.ebuild40
5 files changed, 104 insertions, 0 deletions
diff --git a/app-shells/psh/Manifest b/app-shells/psh/Manifest
new file mode 100644
index 000000000000..934b44aa0a2a
--- /dev/null
+++ b/app-shells/psh/Manifest
@@ -0,0 +1,5 @@
+AUX psh-1.8.1-r3-array-ref-deprecated.patch 1175 BLAKE2B 42c6b1ea5b9db6d58fcabcbaad8746dd25978bd411a938619db46599870d324d9a70ee51ea3eb26163b370946fa20b94822c9ec27df1e067c1182ad9e23949e3 SHA512 52a03f5d5b9716bc28c11ea4726295f7e45d80694a6091fc21bfc32ca6220ebeabd009f96754e4a0c9389087424882d8ea0365f2ad749a9a9fda6e2f6f9ec633
+AUX psh-1.8.1-r3-defined-array.patch 295 BLAKE2B fef59139a5258b02638c2039187e672d1ffddaf69682ce1555964007ab4ed5a27182051a658258ab32148ca31176bbb4ca62f9bddaadc2c956830fc996ce2510 SHA512 69edf4cc81483ec6f9675d1f14b6a9d63a055691dc1f41a08e26b721d3b6081b881db5183df23ebc52459e849ee1ca0f6f5c64c01231c305eef8183145f520c9
+DIST psh-1.8.1-r3.tar.gz 120552 BLAKE2B 68ada33507a780e60e478362406c778ea6f0a68228807c1677371052ef1d40be64c730fc0bf0d1cdd4a915739ecbffcfcd3a16de931c28c3e5ec11a3116920ff SHA512 01e9def98fa89f347ad540cbb0584773de4b7e11595432d7b8e1f1a563725004b898a5fd30f39b01de661ac6ec3274b6cfecdbd7f0bec3fe175119493163ca9a
+EBUILD psh-1.8.1-r3.ebuild 838 BLAKE2B 45668b5ac14ae2bfa0092f2611fca6105ebadb157b30467b9af0184b18124ddc0dfde96e50e13e90464a661932953cd7d5fcffca997c3ffb3db473a357172ab5 SHA512 a3e15fdaeec4947b4653d739955d04b67892008b280e436e289083f990ea199192a544e3039c317558a476e306d9e079f3477714d68703ec0d3709fe1f882b4b
+MISC metadata.xml 353 BLAKE2B 587d9a0cdec11df98a1b70bdfc6ab0fb3007b4f3e3077b189ddec9f1c14690cc60d0d906b9338d68e6f1e94605145619407decb298b4a415be11175be5cb4668 SHA512 b2ed73c0d0a472cc69fed198e266467016b134909c3f8a3d625cb36c409e698c99c30d287999eacc04cc6185a5874861ce0f548b4569a769711c1183fc2c4a3e
diff --git a/app-shells/psh/files/psh-1.8.1-r3-array-ref-deprecated.patch b/app-shells/psh/files/psh-1.8.1-r3-array-ref-deprecated.patch
new file mode 100644
index 000000000000..13c497064ee1
--- /dev/null
+++ b/app-shells/psh/files/psh-1.8.1-r3-array-ref-deprecated.patch
@@ -0,0 +1,37 @@
+From fec038344e05b4fe1b369a979b9ab224343297dd Mon Sep 17 00:00:00 2001
+From: r <rocky@gnu.org>
+Date: Sun, 25 Mar 2012 18:17:45 -0400
+Subject: [PATCH] Get rid of 'Using an array as a reference is deprecated in
+ Psh/StrategyBunch.pm'
+
+---
+ lib/Psh/Strategy/Darwin_apps.pm | 2 +-
+ lib/Psh/Strategy/Executable.pm | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/Psh/Strategy/Darwin_apps.pm b/lib/Psh/Strategy/Darwin_apps.pm
+index cbcbb1d..8c4879e 100644
+--- a/lib/Psh/Strategy/Darwin_apps.pm
++++ b/lib/Psh/Strategy/Darwin_apps.pm
+@@ -44,7 +44,7 @@ sub _recursive_search {
+
+
+ sub applies {
+- my $com= @{$_[2]}->[0];
++ my $com= $_[2]->[0];
+ if ($com !~ m/$Psh::which_regexp/) { return ''; }
+ my $path=$ENV{APP_PATH}||'/Applications';
+ my @path= split /:/, $path;
+diff --git a/lib/Psh/Strategy/Executable.pm b/lib/Psh/Strategy/Executable.pm
+index 7d09119..7767082 100644
+--- a/lib/Psh/Strategy/Executable.pm
++++ b/lib/Psh/Strategy/Executable.pm
+@@ -24,7 +24,7 @@ sub runs_before {
+ }
+
+ sub applies {
+- my $com= @{$_[2]}->[0];
++ my $com= $_[2]->[0];
+ my $executable= Psh::Util::which($com);
+ return $executable if defined $executable;
+ return '';
diff --git a/app-shells/psh/files/psh-1.8.1-r3-defined-array.patch b/app-shells/psh/files/psh-1.8.1-r3-defined-array.patch
new file mode 100644
index 000000000000..660ca34daf44
--- /dev/null
+++ b/app-shells/psh/files/psh-1.8.1-r3-defined-array.patch
@@ -0,0 +1,11 @@
+--- a/lib/Psh.pm 2007-07-21 16:40:44.000000000 +1200
++++ b/lib/Psh.pm 2015-07-18 05:30:29.840928282 +1200
+@@ -367,7 +367,7 @@
+
+ sub defined_and_nonempty
+ {
+- if (!defined(@_)) { return 0; }
++ if (!@_) { return 0; }
+ if (scalar(@_) == 0) { return 0; }
+
+ if (scalar(@_) == 1) {
diff --git a/app-shells/psh/metadata.xml b/app-shells/psh/metadata.xml
new file mode 100644
index 000000000000..5fa8eb473430
--- /dev/null
+++ b/app-shells/psh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gnp/psh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/psh/psh-1.8.1-r3.ebuild b/app-shells/psh/psh-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..00fa615132c7
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${P}" # github--
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+myinst="SITEPREFIX=${D}/usr"
+
+PATCHES=(
+ "${FILESDIR}/${PF}-defined-array.patch"
+ "${FILESDIR}/${PF}-array-ref-deprecated.patch"
+)
+
+src_install() {
+ perl-module_src_install
+ docompress -x "/usr/share/doc/${PF}/pod"
+ docinto pod/
+ dodoc -r doc/*
+}