summaryrefslogtreecommitdiff
path: root/app-shells/powerline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-shells/powerline
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-shells/powerline')
-rw-r--r--app-shells/powerline/Manifest3
-rw-r--r--app-shells/powerline/files/2.7-ldflags.patch15
-rw-r--r--app-shells/powerline/powerline-2.7-r1.ebuild (renamed from app-shells/powerline/powerline-2.7.ebuild)4
3 files changed, 21 insertions, 1 deletions
diff --git a/app-shells/powerline/Manifest b/app-shells/powerline/Manifest
index f86dbfc1c1b4..374971973787 100644
--- a/app-shells/powerline/Manifest
+++ b/app-shells/powerline/Manifest
@@ -1,4 +1,5 @@
+AUX 2.7-ldflags.patch 837 BLAKE2B a1a873a898f3090dab586b968a755e1920ab20158237b9f375a9da2df18d87ba0b3cdf2f671a02ec3163f1ee95436a0c0537b2f7fccc0f8326f1fe25fdcc73c3 SHA512 85872900eeb44e46685b9a229bddd569d06d131ba4c187b44ee916a8ae1e705e10a47b87432c36d855021a0e0e3880c5fe80279a9694ac42f473a06ef3a33565
DIST powerline-status-2.7.tar.gz 233726 BLAKE2B fc7b7d6aa5d8e050af07aeee0aa0b7f6f01b7483ea910b87a7027cd55f726d42e41a008feb07429b21ebbd890b12eb56581b8e47fc30a58de6b902bf14d999cb SHA512 053ab74d250b7d835a5f8ec9cb7da4e890f0f50d31be9bab4b393a85e087a6fc010e58d6b3fa530cf39c10671345d032ca1fa9c0f7887a89fea8a4e69b7f1517
-EBUILD powerline-2.7.ebuild 697 BLAKE2B bbf4002244911524b210c3f051c9d5c2e2ec380fbaa3a413f9fbc98b357cc05e77bb2f5bf145d70c50630245e6f03f7dc73864b81544d09d3c0716dc29c0506d SHA512 05f969b77f3ad5033078bc79de74d6ac5b5717d18fcde20c37153aae549cc3756985f96585f11e594fde744b6e1c86ac87143826aaaa0dcb6b6e3ee715d498a6
+EBUILD powerline-2.7-r1.ebuild 743 BLAKE2B bd93e5352b00bd1bd73db6e5dc7d6ee85e0f4d30ec05e7b62d54ef79d7ba368a8d560b2d008cb6476716f19133614aea9a6eaf52ec3cd6aa126462c87d4a5bbd SHA512 c967665b40de94391df7a9e33cc20371fc7d2146865d63ec6c9bbb4a6ca0441e8bf16fd09aed8ff28451821471df7853aa8f3a21c3aaf6e4fd74a6abe49757a4
EBUILD powerline-9999.ebuild 730 BLAKE2B 5d75497b2323d373e00df5deabaa205d6286363f4181f409e8cecaf614b0bb7ed4c3b624b61fe54f5d94c27307cdf97bd69109e8ba508b62e76a1c9693428bdf SHA512 c08cdb58cc2b88a88860eefdcc03a7894b4bf2765ff0ed23cf257c36c4436e8153ed336838c13035e21334c7571452bb48f4d098b60047100a4add9fd88b1a34
MISC metadata.xml 620 BLAKE2B 3c392d83a62425429cc89d0ac8dff925d98a392aa1d84bc0c7e84dd2871ded1566b0b66afe34b201672a51b23650cc2e18320c5e4e98b4b5042099340cae4b56 SHA512 10f3ce6affeed34d2b48a922a64eb2b1b1a628ed9d5e9a78f92eec3b264d633ce75b09e83e2cc3deae074ac27cd9f1bd2adcdb5f77e8deacdcd876d849977f60
diff --git a/app-shells/powerline/files/2.7-ldflags.patch b/app-shells/powerline/files/2.7-ldflags.patch
new file mode 100644
index 000000000000..077c28af2a07
--- /dev/null
+++ b/app-shells/powerline/files/2.7-ldflags.patch
@@ -0,0 +1,15 @@
+diff -Naur powerline-status-2.7/setup.py powerline-status-2.7.new/setup.py
+--- powerline-status-2.7/setup.py 2018-08-12 14:41:44.000000000 -0500
++++ powerline-status-2.7.new/setup.py 2020-06-01 14:56:25.977968288 -0500
+@@ -30,9 +30,10 @@
+ from distutils.ccompiler import new_compiler
+ compiler = new_compiler().compiler
+ cflags = os.environ.get('CFLAGS', str('-O3'))
++ ldflags = os.environ.get('LDFLAGS', str(''))
+ # A normal split would do a split on each space which might be incorrect. The
+ # shlex will not split if a space occurs in an arguments value.
+- subprocess.check_call(compiler + shlex.split(cflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
++ subprocess.check_call(compiler + shlex.split(cflags) + shlex.split(ldflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
+
+ try:
+ compile_client()
diff --git a/app-shells/powerline/powerline-2.7.ebuild b/app-shells/powerline/powerline-2.7-r1.ebuild
index 946e4c10304a..623ac6d9568c 100644
--- a/app-shells/powerline/powerline-2.7.ebuild
+++ b/app-shells/powerline/powerline-2.7-r1.ebuild
@@ -25,3 +25,7 @@ RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/2.7-ldflags.patch
+)