summaryrefslogtreecommitdiff
path: root/app-shells/posh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/posh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/posh')
-rw-r--r--app-shells/posh/Manifest3
-rw-r--r--app-shells/posh/metadata.xml7
-rw-r--r--app-shells/posh/posh-0.13.1.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/posh/Manifest b/app-shells/posh/Manifest
new file mode 100644
index 000000000000..e89787da33fa
--- /dev/null
+++ b/app-shells/posh/Manifest
@@ -0,0 +1,3 @@
+DIST posh_0.13.1.tar.xz 267436 BLAKE2B f534f64595eda7649a146555238309aba00ec79d53206b17c91ba9ed44ab47794541952af670c5040133d164167e8f2bc844fc4b3b646035e0d08e8495d7aedf SHA512 957fc2924ab8f634007db2e15ecdbb8a1c60ffb4917c127c1583c05e222f598a564906cc40c869c95d79995ea85af24010780e7d36d44a5907a691aa9044f23a
+EBUILD posh-0.13.1.ebuild 594 BLAKE2B 3597877c2471425d0726b7d81f66f86c567cff15e11ab6e37023035392c9fecd3ae26263a1062dac89a0ff8a0d1da3c3bf0a33ace40deaeb8774787e84d24526 SHA512 6046007613ec2fc0a8e61f6fe4e97012a34e9cbbb512b2d5009f658913147ae23e4b43c8311fa35d7f81f26a1606b226f2603ba3454a79bb1cadee08d33d2f0c
+MISC metadata.xml 217 BLAKE2B 2c342b84369a3ba13606f35f163ee0aab11a086c23c83066fb5fd7d0ffcac5282b2cbb228982745c8ae1c1575b7d1605556f3562175ee150de6c701d86e347c8 SHA512 94cad0e7f10d53a2ee488ff9be4c417377f7cc6fed1ea4bad878364978cdbeb648974764477a18d2b222ad9111082ef0e00b14832ec7318646a47b56c58c828e
diff --git a/app-shells/posh/metadata.xml b/app-shells/posh/metadata.xml
new file mode 100644
index 000000000000..a8f60369627b
--- /dev/null
+++ b/app-shells/posh/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/posh/posh-0.13.1.ebuild b/app-shells/posh/posh-0.13.1.ebuild
new file mode 100644
index 000000000000..0291aa09ccfd
--- /dev/null
+++ b/app-shells/posh/posh-0.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="https://salsa.debian.org/clint/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+
+S=${WORKDIR}/posh
+
+src_prepare() {
+ default
+ # the tarball apparently contains outdated files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --exec-prefix="${EPREFIX:-/}"
+ )
+ econf "${myconf[@]}"
+}