summaryrefslogtreecommitdiff
path: root/app-shells/posh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /app-shells/posh
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'app-shells/posh')
-rw-r--r--app-shells/posh/Manifest2
-rw-r--r--app-shells/posh/posh-0.13.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/app-shells/posh/Manifest b/app-shells/posh/Manifest
index cec5c652f249..5d55c792f50e 100644
--- a/app-shells/posh/Manifest
+++ b/app-shells/posh/Manifest
@@ -1,3 +1,5 @@
DIST posh_0.12.6.tar.xz 268872 BLAKE2B 8fef9e682344ca40b83c68ea639d1d684a6d743c97e07e3279b6d11928b0b28e2c8014f1d11e36a3374851c4ad41f078ff7e630954740c460318a70b8ed42677 SHA512 2b862264dd13c840facb158f1e2731dd1f11c7a567308feb6bd80fd5a7ea4d8e383cc13a0819f90da5fdad70d0adcc81e5adf2bd69a7a171e2e874f82509123c
+DIST posh_0.13.1.tar.xz 267436 BLAKE2B f534f64595eda7649a146555238309aba00ec79d53206b17c91ba9ed44ab47794541952af670c5040133d164167e8f2bc844fc4b3b646035e0d08e8495d7aedf SHA512 957fc2924ab8f634007db2e15ecdbb8a1c60ffb4917c127c1583c05e222f598a564906cc40c869c95d79995ea85af24010780e7d36d44a5907a691aa9044f23a
EBUILD posh-0.12.6.ebuild 481 BLAKE2B 723f1cb8f7104f8956451e6d6f6c827cb325686dd07c99692dd8397e9a0d68a47b838605f901962ca591b8b41d6c14f133bcdb324c2d6c92af243bc69dd33413 SHA512 ecc86c5799f650bc85f37badc9be28faef49591bbec0c9f0191fa1308946f9edc2f1d631c81ab9e62d88a00cefb68b4a3d66229b3d09a21a8226c1b6ccdd9564
+EBUILD posh-0.13.1.ebuild 487 BLAKE2B 0a186c586b194f3363f442fbde4cf0dd0d060c826aaf29e9c370b393678b888e44aadf40189c22c1ab160fccb046fbd32a1e653fc3af7ee7817277523129e597 SHA512 78ae072784d4b62c54c07072794faed092d2887777087a4e3627853c88043e227a922126499717ce085224bfc2eb7c5dc98049f24f01486307cf2853f58de0c9
MISC metadata.xml 217 BLAKE2B 2c342b84369a3ba13606f35f163ee0aab11a086c23c83066fb5fd7d0ffcac5282b2cbb228982745c8ae1c1575b7d1605556f3562175ee150de6c701d86e347c8 SHA512 94cad0e7f10d53a2ee488ff9be4c417377f7cc6fed1ea4bad878364978cdbeb648974764477a18d2b222ad9111082ef0e00b14832ec7318646a47b56c58c828e
diff --git a/app-shells/posh/posh-0.13.1.ebuild b/app-shells/posh/posh-0.13.1.ebuild
new file mode 100644
index 000000000000..b9d6fe69c69b
--- /dev/null
+++ b/app-shells/posh/posh-0.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="https://salsa.debian.org/clint/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+
+S=${WORKDIR}/posh
+
+src_configure() {
+ local myconf=(
+ --exec-prefix="${EPREFIX:-/}"
+ )
+ econf "${myconf[@]}"
+}