summaryrefslogtreecommitdiff
path: root/app-shells/posh/posh-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-shells/posh/posh-0.14.1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-shells/posh/posh-0.14.1.ebuild')
-rw-r--r--app-shells/posh/posh-0.14.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/posh/posh-0.14.1.ebuild b/app-shells/posh/posh-0.14.1.ebuild
new file mode 100644
index 000000000000..9ebc1b24bbaf
--- /dev/null
+++ b/app-shells/posh/posh-0.14.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=posh-debian-${PV}
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="https://salsa.debian.org/clint/posh"
+SRC_URI="
+ https://salsa.debian.org/clint/posh/-/archive/debian/${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+ BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --exec-prefix="${EPREFIX:-/}"
+ )
+ econf "${myconf[@]}"
+}