summaryrefslogtreecommitdiff
path: root/app-shells/posh-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-shells/posh-git
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-shells/posh-git')
-rw-r--r--app-shells/posh-git/Manifest3
-rw-r--r--app-shells/posh-git/metadata.xml14
-rw-r--r--app-shells/posh-git/posh-git-1.1.0.ebuild36
3 files changed, 53 insertions, 0 deletions
diff --git a/app-shells/posh-git/Manifest b/app-shells/posh-git/Manifest
new file mode 100644
index 000000000000..5d660ee17cbd
--- /dev/null
+++ b/app-shells/posh-git/Manifest
@@ -0,0 +1,3 @@
+DIST posh-git-1.1.0.tar.gz 90089 BLAKE2B 3759c8382d1e1c48cd5ee40668ae5e3f8edff3ae73861af904a1a4674af52f57e010e2f187813caf728d750b5f492d15860e58a57a24f6e3aa65fa5eb2b7a9cc SHA512 1aa8150c07d212476527c32a8a6acad903811de0068147b43810e3aa897a837c7adf69838195654ca26715ec7e736e56897190b344c6f432374b1d2493e5b891
+EBUILD posh-git-1.1.0.ebuild 711 BLAKE2B dec621edd2f03463b3fba23cb46efb3d4607430af258bf2b4b3d431dcd38d70ffd2c300eaa7f757ef56ae683645cfd4f6cdc01cc9557eea69ba9e6699844d24d SHA512 3107c0da3ca7f827ff9a13b8f8896b99691e92e61c8099be132430c312c7d2c0aa2a384fd833de6acd5d6fe710d31c28e6e011df48b3c6e5c7af171053af8566
+MISC metadata.xml 503 BLAKE2B 21d07b713e5b8fa76acd8caf7cb9dde2694b843344322bb16d3f1fef6db3bb54ba556d184c8427bb97ed5ad038b6b7fcf3c03c5188e3c21f6083a90227262895 SHA512 342cc92848846505450012dc59e2936d224ff4642c79038bda40031eaf1d8bbac880823f941ccb067d89be8f7a69185fb0c2bad7d4422857379fff846265a654
diff --git a/app-shells/posh-git/metadata.xml b/app-shells/posh-git/metadata.xml
new file mode 100644
index 000000000000..b95ffb970544
--- /dev/null
+++ b/app-shells/posh-git/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/dahlbyk/posh-git/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://gitlab.com/dahlbyk/posh-git/issues/</bugs-to>
+ <remote-id type="github">dahlbyk/posh-git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-git/posh-git-1.1.0.ebuild b/app-shells/posh-git/posh-git-1.1.0.ebuild
new file mode 100644
index 000000000000..72a1c2f7cce4
--- /dev/null
+++ b/app-shells/posh-git/posh-git-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PowerShell environment for Git"
+HOMEPAGE="http://dahlbyk.github.io/posh-git/
+ https://github.com/dahlbyk/posh-git/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dahlbyk/${PN}.git"
+else
+ SRC_URI="https://github.com/dahlbyk/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ virtual/pwsh:*
+ dev-vcs/git
+"
+
+DOCS=( CHANGELOG.md ISSUE_TEMPLATE.md README.md profile.example.ps1 )
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins -r src/.
+
+ einstalldocs
+}