summaryrefslogtreecommitdiff
path: root/app-shells/pdmenu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/pdmenu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/pdmenu')
-rw-r--r--app-shells/pdmenu/Manifest4
-rw-r--r--app-shells/pdmenu/files/pdmenu-impl-dec.patch16
-rw-r--r--app-shells/pdmenu/metadata.xml7
-rw-r--r--app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild63
4 files changed, 90 insertions, 0 deletions
diff --git a/app-shells/pdmenu/Manifest b/app-shells/pdmenu/Manifest
new file mode 100644
index 000000000000..9b0721b7186e
--- /dev/null
+++ b/app-shells/pdmenu/Manifest
@@ -0,0 +1,4 @@
+AUX pdmenu-impl-dec.patch 400 BLAKE2B b3525ccfd012827225b62ffb1ffd47a5aefc9c2de0ec54e1829e43d067e8e68f46c1527ed6d39cbf9ff0d8ee2d32ea837fe74081f692bbaddc5420473adb6ad1 SHA512 9a676d9384b575466b28ece1ce84d346a6f193288ed686aea94bcebe8f73a0e38723590356cbe822e34644b5b103adab6317b654cfddc961a40b005bc0e0fb0a
+DIST pdmenu_1.3.4.tar.gz 161002 BLAKE2B 51fb2d0384df4b545f908e081e87a1d7414b22a5c1d9e2dffb2ac5f7d4069c7e2e9de8a1bde459a1fed34c8159f37aff8ef20b69e4817e28f9730500b26e654d SHA512 2540b3040a799f4682de1014f8da750501000cef7080ea24b066a7e44971e33452a25e3885849bc47a156727641c4acb8d1268d3c16a2aab2cb37d510f50f3ad
+EBUILD pdmenu-1.3.4-r1.ebuild 1286 BLAKE2B ec59663b35b77ed3e50a8f8c15b659d696ba238526667aa6ae03304b20b11b791ff712d162ec3bd5d52fd76aae36d8c25d88ae83a5cdb32cc04c58edeaf5aadf SHA512 4bceb51b5c06a2501b6622bfa1633cc54d5987f46499ef29313e175ff4f948ae6aef94bccd5171f99a3a5c315257fe2fc06c5db65c1a07651130fa1c6dc28f43
+MISC metadata.xml 220 BLAKE2B eabf3517ba7e5b67320254eeb2b07adf1dbe0c3432b693973bc25a3e3dc8ed160b7313f9f8ae64d994ac272487b785f33202d9640bb5a7ace9f56ceb42978a19 SHA512 1db105eebacb6c7d44fd17746981e6e24badb2e81327410aa935a7603379cfcc8f3cf27dcf4e9d870cea2f73f6a15cf052e3e785205095ea9a93d72980ff71cc
diff --git a/app-shells/pdmenu/files/pdmenu-impl-dec.patch b/app-shells/pdmenu/files/pdmenu-impl-dec.patch
new file mode 100644
index 000000000000..c0cd7ce3ac99
--- /dev/null
+++ b/app-shells/pdmenu/files/pdmenu-impl-dec.patch
@@ -0,0 +1,16 @@
+ src/actions.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/actions.c b/src/actions.c
+index d42a63a..1f5a0d1 100644
+--- a/src/actions.c
++++ b/src/actions.c
+@@ -30,6 +30,8 @@
+ #include <libintl.h>
+ #define _(String) gettext (String)
+
++#include <ctype.h>
++
+ /* Handle a control c by either exiting pdmenu or doing nothing. */
+ void Handle_Ctrl_C() {
+ if (Q_Exits) {
diff --git a/app-shells/pdmenu/metadata.xml b/app-shells/pdmenu/metadata.xml
new file mode 100644
index 000000000000..294c350c6960
--- /dev/null
+++ b/app-shells/pdmenu/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild b/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..55be86bd2f44
--- /dev/null
+++ b/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple console menu program"
+HOMEPAGE="http://joeyh.name/code/pdmenu/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/pdmenu_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="nls gpm examples"
+
+DEPEND="
+ sys-libs/slang
+ gpm? ( sys-libs/gpm )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-impl-dec.patch
+)
+
+DOCS=( doc/ANNOUNCE doc/BUGS doc/TODO )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
+ -i Makefile || die
+}
+
+src_configure() {
+ CC=$(tc-getCC) econf \
+ $(use_with gpm) \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ use examples && dodoc -r examples
+ mv "doc/${PN}.man" "doc/${PN}.1" || die
+ mv "doc/${PN}rc.man" "doc/${PN}rc.5" || die
+ doman "doc/${PN}.1" "doc/${PN}rc.5"
+ einstalldocs
+}
+
+pkg_postinst() {
+ ewarn "Note this part from man page: Security warning! Any exec command"
+ ewarn "that uses the 'edit' flag will be a security hole. The user need"
+ ewarn "only to enter text with a ';' in it, and they can run an"
+ ewarn "arbitrary command after the semicolon!"
+}