summaryrefslogtreecommitdiff
path: root/app-shells/mpv-bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/mpv-bash-completion
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest5
-rw-r--r--app-shells/mpv-bash-completion/metadata.xml16
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild51
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild51
4 files changed, 123 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
new file mode 100644
index 000000000000..871a40d76257
--- /dev/null
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -0,0 +1,5 @@
+DIST mpv-bash-completion-3.3.16.tar.gz 20125 BLAKE2B 1350445ea05474e553ade334c1f11e97828df11143021920a25787a295d6e870595e35dda6ccd048ed4e01e0e85443a5902893fed1aa1525e875649a93ef632d SHA512 d962cc911d571b0345ddee22ecae6faef307f2da44642d6db5223fb0e51d2b2087b038e1964cf8f1ed683bb95a3268a8ffc1fff2759561100b23921406a0e31f
+DIST mpv-bash-completion-3.3.17.tar.gz 20873 BLAKE2B 5e44b315a4f148c27768a3b0c29d609b679e3d489dd79803795a75a9289816ed13797cc04c748410ba3302a2619dedad21772f2d914b2c3ff5c73189e4e348df SHA512 a0b1ae4b07bd3e5fc95fea135aa5391d0efb0d2c1e4ccbb712cf0911b9e07b23a7bfb27d43b615988610f545f1bc62226998295573480ab657e3b18966d48991
+EBUILD mpv-bash-completion-3.3.16.ebuild 1120 BLAKE2B d0f980a20b970ba099c0d06ded70aab17730eb127a65649f603a66a45bd17381299bfcf2c21effd2eeb5a318245400a54dc0fa9719782164e23ae1b700870c68 SHA512 f57a73c90eb63618b9690ef7a79346db3f1ffc8778a2fa4040470567073ed7ab38622e21201c188dac57ec646a722ae64b30555c8e66f7e6de856e6047c0bb57
+EBUILD mpv-bash-completion-3.3.17.ebuild 1122 BLAKE2B c0d40d8b06256e52105994764f91e2ad852e4ab0df58e6942bbe067d44c79d8b2bec4df093b40e4afa7f314a896722f9e089f6c611c4d4eaa2646b9ace819c8b SHA512 8a0cf0749c3cb61bf9e5ac3bbc67e9036dfbb400455d3a3ea0e55a07b1c66ec3f68a2331ede97e41ec5f900db68aa2a9d7434ef48cd3ce0d9c0e8ea330395eed
+MISC metadata.xml 533 BLAKE2B f2896156a0988c66549245ff93ebb7599d006b41cb1731d0e7bc720a62680575feb02cfd8b0d1eb35a9472308a31711f9731a9dd41c7d5da673050c7a8994f8d SHA512 6ecdf8effd7f09950473e954cb401c848f46a93ae8b7f0c9ba601fa9e11bfb75114f32fa13e1a77d4dc2d19377ae35a61493cf4cedcb359ea319e02df8538ebc
diff --git a/app-shells/mpv-bash-completion/metadata.xml b/app-shells/mpv-bash-completion/metadata.xml
new file mode 100644
index 000000000000..1d75e0fd49a8
--- /dev/null
+++ b/app-shells/mpv-bash-completion/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/2ion/mpv-bash-completion/releases</changelog>
+ <remote-id type="github">2ion/mpv-bash-completion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild
new file mode 100644
index 000000000000..bb3736da0fec
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.25.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ # Prevent access violations from completion generation.
+ # See Gentoo bug 656086.
+ addpredict /dev/dri
+
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild
new file mode 100644
index 000000000000..2aca0b8cc661
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.25.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ # Prevent access violations from completion generation.
+ # See Gentoo bug 656086.
+ addpredict /dev/dri
+
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}