summaryrefslogtreecommitdiff
path: root/app-shells/mpibash/mpibash-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/mpibash/mpibash-1.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/mpibash/mpibash-1.3.ebuild')
-rw-r--r--app-shells/mpibash/mpibash-1.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/mpibash/mpibash-1.3.ebuild b/app-shells/mpibash/mpibash-1.3.ebuild
new file mode 100644
index 000000000000..76bbce43cda2
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}