summaryrefslogtreecommitdiff
path: root/app-shells/liquidprompt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-shells/liquidprompt
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-shells/liquidprompt')
-rw-r--r--app-shells/liquidprompt/Manifest2
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.1.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
index 838d11839209..b34d946dfe92 100644
--- a/app-shells/liquidprompt/Manifest
+++ b/app-shells/liquidprompt/Manifest
@@ -1,5 +1,7 @@
DIST liquidprompt-2.0.3.tar.gz 539054 BLAKE2B c94375e0def1764103afe04bb47ff25ced2aeb940b45392bea8a2889ce88d1ea0e03efc0652ec8bc873b9910bee7208e48aaef9a846760177049cc550a5cd8b0 SHA512 a77f1548dd233de9877b2b5dd4a64f05ef03890917486792eb1c362708ab0b635c517cc2a3ddc82731940017f209f626d177a4ac0b5554566faa720a7d88b550
DIST liquidprompt-2.0.4.tar.gz 536123 BLAKE2B 181fe4c59d1a68e03893b1a2144d6b800d8d950a48d38b12fa04aafb01384a08d5b95741a9fac524b353cf7f1b5e09f838d45222009dfb94dcc890ec2a6ab985 SHA512 611931c5572abf1471a2cac1a88d91fadb935e97a3c32bb0ff8a5cc007ac96dd7a88575feecdf033a77226b769504fde93d4afd93fa60277eafdb5f96fb18bcb
+DIST liquidprompt-2.1.1.tar.gz 621781 BLAKE2B b23dcbf44f6b0b3a56aa59fffc38336b00be5c3066729445be6b3cb53fb4cb39e12c3f4a31e30a2bfca2abc7a5b02d4015662fb8d303d42406976b6f4b24d1b9 SHA512 88511bb74355c1ffd9ab710170905daeac673073083e81ec165bf4dad47377a47eb5eb6f387010439456c6e6df059ff640bcde8e16eeb60621d1c3ae6b502963
EBUILD liquidprompt-2.0.3.ebuild 818 BLAKE2B 29cef421d5806b410ebe133d7985f4cd78ce1dadb1f5cd0ef2306968700dffd6d4270b4a41747287778d5b60bf3f5f14c32193b56e98fb9107a119a1b21e32f9 SHA512 9374d1a7ec9644cfc87e4123a165dc904d029b020b3bc037d165b26f75e04373166fb9719cb22b6b97a198a09ecc8445a2645673d1684eea5d2ef126a05d9160
EBUILD liquidprompt-2.0.4.ebuild 818 BLAKE2B 60c6a123ff127bec28223470cf27282530a1f756cbec3e5ee7da506d5d6a564f23018004df03c4b8b119ef1ccc616bdc364d8a3847452274a7dfb373002dde9d SHA512 bbdb46176949b2a172ec35c9658e441091b7ed1a36d30e35066df1ee101415ba0089306fa2fee6d9efe00ce4b4a1b40e38bb9f29449cf22f072185701ffe45e0
+EBUILD liquidprompt-2.1.1.ebuild 818 BLAKE2B 60c6a123ff127bec28223470cf27282530a1f756cbec3e5ee7da506d5d6a564f23018004df03c4b8b119ef1ccc616bdc364d8a3847452274a7dfb373002dde9d SHA512 bbdb46176949b2a172ec35c9658e441091b7ed1a36d30e35066df1ee101415ba0089306fa2fee6d9efe00ce4b4a1b40e38bb9f29449cf22f072185701ffe45e0
MISC metadata.xml 335 BLAKE2B 35124b3abcc1162303d8e666abc6d5e024191604555500cdf5f21ba3b45d3c815cef3e14ce4e8052b0d698f9ce4ac83fc22585382559989922816ea7128b59c6 SHA512 12fa46e8150943e9c7175079b67912a0f9cede1bc6892781eeb97c635f99243e32a24ca60a2caa3f2a19587f4c5a134b84f90f95b018c93e6a523001e0e8e806
diff --git a/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild b/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild
new file mode 100644
index 000000000000..aed3cbeb58e8
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins liquid.theme
+ doins liquid.ps1
+ doins -r themes
+
+ insinto /etc/
+ newins liquidpromptrc-dist liquidpromptrc
+}