summaryrefslogtreecommitdiff
path: root/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'app-shells/ksh/ksh-2020.0.0_alpha1.ebuild')
-rw-r--r--app-shells/ksh/ksh-2020.0.0_alpha1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild b/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
new file mode 100644
index 000000000000..4927a8e7fe18
--- /dev/null
+++ b/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="https://github.com/att/ast"
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="https://github.com/att/ast/releases/download/${MY_PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="!app-shells/pdksh"
+
+src_install() {
+ meson_src_install
+ dodir /bin
+ mv "${ED}/usr/bin/ksh" "${ED}/bin/ksh" || die
+}