summaryrefslogtreecommitdiff
path: root/app-shells/irregular
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 00:49:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 00:49:58 +0000
commit2c18b7f7fb2885d27960657c60906ef0bac0681e (patch)
tree91c24c33362baf968c4c08f3a7220157b57a374f /app-shells/irregular
parentbc7e0dbdbd194a8c2e09f82e1a5a4ea5e1b556f4 (diff)
gentoo auto-resync : 19:03:2024 - 00:49:58
Diffstat (limited to 'app-shells/irregular')
-rw-r--r--app-shells/irregular/Manifest3
-rw-r--r--app-shells/irregular/irregular-0.7.8.ebuild34
-rw-r--r--app-shells/irregular/metadata.xml13
3 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/irregular/Manifest b/app-shells/irregular/Manifest
new file mode 100644
index 000000000000..23987489a8af
--- /dev/null
+++ b/app-shells/irregular/Manifest
@@ -0,0 +1,3 @@
+DIST irregular-0.7.8.tar.gz 530657 BLAKE2B e6a350d3ba582bfcfd23a2ff8b3a992fa43a4dbd0fbf18eb9bdb1f5c76f8140c1d27b02cc6feb28bfe1c45be480f72ca8a592b0bb54efb529c78904a79f95019 SHA512 c4a2a8cfe202ec7222c038125b2fed4c58b6611e03bff836b3d90b7e0c6a932a4d00e430cd6212b43fa30e471c8ba8fdbcf0f43474f89c84078386f55575b635
+EBUILD irregular-0.7.8.ebuild 806 BLAKE2B 147bf167bcb22b6e80a5bf60ace7a0d682692c4aaeb5b09d332a3b1d555e55f0dcc775037633c065d33bcdb004def86cec0bf7bb71a32f020c80c6467283ae17 SHA512 e48636128b4c22c7c5f244ae97fee0e4fc081a273b0094e42ae19d472071281debc9c9633016277617534911b25f56a227f5b97a9f042e0d93d9ce7ecd9c0013
+MISC metadata.xml 433 BLAKE2B 599ecbe58562c297c4b376a49188548bef45bbfb0779553331dfb9e92ae699e6992fa71bea5fde9d543c5be70ca908710c0b5b2525ef8af05845b1fda35495f7 SHA512 9eb054e527e06f2a442b11eec27708eaf36542cac8a3ff5b34310dcadbc795a0b3b314f029562fbea9da67b136c6e3463dc010c283add7528e75507f49c59a57
diff --git a/app-shells/irregular/irregular-0.7.8.ebuild b/app-shells/irregular/irregular-0.7.8.ebuild
new file mode 100644
index 000000000000..fbaf088f26c5
--- /dev/null
+++ b/app-shells/irregular/irregular-0.7.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell module that helps to understand, use, and build regular expressions"
+HOMEPAGE="https://irregular.start-automating.com/
+ https://github.com/StartAutomating/Irregular/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN^}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN^}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN^}/${PV}"
+ doins "${PN^}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Formatting RegEx Types en-us
+
+ dodoc *.md
+}
diff --git a/app-shells/irregular/metadata.xml b/app-shells/irregular/metadata.xml
new file mode 100644
index 000000000000..57f0f430cade
--- /dev/null
+++ b/app-shells/irregular/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/StartAutomating/Irregular/issues/</bugs-to>
+ <remote-id type="github">StartAutomating/Irregular</remote-id>
+ </upstream>
+</pkgmetadata>