summaryrefslogtreecommitdiff
path: root/app-shells/invokebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
commite67d5b4ba05349b3bf4229d0cf7d069809c4420e (patch)
tree0fe2174d8edf159924d772ad279f37faba8d5b6a /app-shells/invokebuild
parent249ae8c1a241b514fc83737660927ee175091346 (diff)
gentoo auto-resync : 28:12:2023 - 01:37:43
Diffstat (limited to 'app-shells/invokebuild')
-rw-r--r--app-shells/invokebuild/Manifest3
-rw-r--r--app-shells/invokebuild/invokebuild-5.10.5.ebuild32
-rw-r--r--app-shells/invokebuild/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/invokebuild/Manifest b/app-shells/invokebuild/Manifest
new file mode 100644
index 000000000000..7917605254ce
--- /dev/null
+++ b/app-shells/invokebuild/Manifest
@@ -0,0 +1,3 @@
+DIST invokebuild-5.10.5.zip 40940 BLAKE2B d67d7b9e1a90af8b898558910bc766a7f4e186abbb678f50940f5783c028d0ca16ec77e394dc486c3553b03016581ce73b6f73f9f68271bad53cfafdb7f39de3 SHA512 4210a31885f6d6126b70aa6f2c8bbf41d62e404c65637f9d5aa7daa8cb8a9e052595ebd28b7b2794a7107c01193fa02cd3f6a8c8c456f2ce2d0f8e13adfc7668
+EBUILD invokebuild-5.10.5.ebuild 609 BLAKE2B 44ce4c87ecf79937f343fdcfc77b429dd921eb273f40960f086898230d84b58fa1bcf740e437cbfa496f13180b5de49378706a08551d9ebb16582cb658dfa068 SHA512 333dd57014fa4ea47326e2f01b9eae84e11d2e34556e304e3e465e42b5bd55029f96c1f5729f26d785a185f95139210d66c632cdce7f69f0072ac16708cc0469
+MISC metadata.xml 429 BLAKE2B 43dd8d8680750dc61b520d7da190aeb117d5573dc506ef6a284c5ed1273352cfba03467b683b8b435b68c8b787b59e6d6e1e3d27e1abf233235c615956826922 SHA512 426160c29dc9db284fe097c8ea6fe12916367b6441545ea0810ec057c8f8fe4375ba3d9bd0844e52f6ffeb82f80dee43b2d5233d499ad42d96028cbdab199ae6
diff --git a/app-shells/invokebuild/invokebuild-5.10.5.ebuild b/app-shells/invokebuild/invokebuild-5.10.5.ebuild
new file mode 100644
index 000000000000..583ef0ac859b
--- /dev/null
+++ b/app-shells/invokebuild/invokebuild-5.10.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Build and test automation in PowerShell"
+HOMEPAGE="https://github.com/nightroman/Invoke-Build/"
+SRC_URI="https://www.powershellgallery.com/api/v2/package/${PN}/${PV}
+ -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ virtual/pwsh:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm -f -r '[Content_Types].xml' _rels package || die
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/InvokeBuild/${PV}"
+ doins -r .
+}
diff --git a/app-shells/invokebuild/metadata.xml b/app-shells/invokebuild/metadata.xml
new file mode 100644
index 000000000000..463c3cf6a20b
--- /dev/null
+++ b/app-shells/invokebuild/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/nightroman/Invoke-Build/issues/</bugs-to>
+ <remote-id type="github">nightroman/Invoke-Build</remote-id>
+ </upstream>
+</pkgmetadata>