summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-zsh-completions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/gentoo-zsh-completions
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/gentoo-zsh-completions')
-rw-r--r--app-shells/gentoo-zsh-completions/Manifest6
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild27
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild27
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild27
-rw-r--r--app-shells/gentoo-zsh-completions/metadata.xml11
5 files changed, 98 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/Manifest b/app-shells/gentoo-zsh-completions/Manifest
new file mode 100644
index 000000000000..2f7ca4ff9a2c
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/Manifest
@@ -0,0 +1,6 @@
+DIST gentoo-zsh-completions-20150103.tar.gz 23759 BLAKE2B 9e48cad8b98df4de9479f06ab394e689f2169c6b52e062806b2051f18b86a6f80b660f472fe48b94bb0aff10095d7fcb9e097aa38710d6f3969cb03cfa4aff5c SHA512 4d87edda071d98672df79e3dbb9565757c0738bc50751d31e5dfefab4f17523387fb2342906ecc0600ce86d888ab4a785756bbb1daf37ca56a3ce1af9e5ae173
+DIST gentoo-zsh-completions-20180228.tar.gz 23246 BLAKE2B a6e4004aa7592cbb097cad55fe9d7286f39bd264d8c463ed22e665ca6a60732b0bc8678a0ac09715e2f34abbadd0e4466d783fdb228ce364bcbe13fb7f097649 SHA512 2b3dcfb910e297eb2f03f4ad9f3749b379ceb60f8b6cbcb7c7d03b7921b79aa21f8d3aa50931c5d4eff52f988a208f1a810c6da7c20720be7a3f2ce4a4564788
+EBUILD gentoo-zsh-completions-20150103.ebuild 771 BLAKE2B c65368b319701900a3df63d3fc927b784776c07678bc040926d6e2629f4d2424028ed0485bac0963e4791ce65febe8043e59d96bc482e506bdf059ce6adebe28 SHA512 f9eb8af6a85e8d5a0ad67ad9c96c26cc9471e484bab7d88ea921a0d49e8d9fccf3edf47c8785a8ad356904808d3724bd37c121158ddce8d32df16a228122cf24
+EBUILD gentoo-zsh-completions-20180228.ebuild 780 BLAKE2B 29e5e1a3f80ebf8863be26da8831e4681d7339eca2575196f41e1aad595d9beef708a8fbbc908db1e0479c53a8d0d0a45eb89bdea6a2730baec658562b161244 SHA512 a2b5768576f3e5b58568618fcf7a6aedef113095f7d2156bd927e4fc3ee28c1b41ed3d94114e2c2af64af832170c1d80043424fc8a7f36e8d77b049e77c57668
+EBUILD gentoo-zsh-completions-99999999.ebuild 771 BLAKE2B 7436e2dd771079cc966ec435d850a24086e82c9e33c22dd8a1b0f731ffe8c34701f2ab1718d2699fb1d97bf986901442ecf5bf380f7feba63531831fac9a338a SHA512 51c32e89ab85b75c7415c85dfa06670423a3e1944be0cce715fb416a238196faebc881220c275853a18d69153bf13607638ea127e15727df562e10106f104270
+MISC metadata.xml 350 BLAKE2B c8d3cbed9f1d2cc6511612f05448d7826ca031448c936a2ec18ad2bc8af628c3531a248c63cc2f46f0037c2b9305051df2b3d05808d5d7721c39560c0621bfd9 SHA512 06072032aaba8a33b43231772067bbadedc05abe289933b54108d30e6acd81fab23e621db91dd1269df46a171bb11c3903e8e942a7ce964c1229e44912702d59
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild
new file mode 100644
index 000000000000..cf137815c472
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild
new file mode 100644
index 000000000000..3cc5d5efac76
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
new file mode 100644
index 000000000000..f25ef6864f7d
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/metadata.xml b/app-shells/gentoo-zsh-completions/metadata.xml
new file mode 100644
index 000000000000..bb95fea0f268
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gentoo/gentoo-zsh-completions</remote-id>
+ </upstream>
+</pkgmetadata>