summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild')
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
new file mode 100644
index 000000000000..a7aa565f0652
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/radhermit/gentoo-zsh-completions"
+SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins _*
+
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}