summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-bashcomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
commit55b20c97078ded20d0e7c6b3ef33d673c861d8b4 (patch)
tree92579cc158fd711b487e332cf87f87f3cf489d69 /app-shells/gentoo-bashcomp
parent8c9b482f4679667d7b439749d9a9c65d559d11b8 (diff)
gentoo auto-resync : 14:03:2023 - 00:16:42
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/Manifest2
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index 30c63af8d875..967ef21015da 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1,3 +1,5 @@
DIST gentoo-bashcomp-20190211.tar.bz2 21508 BLAKE2B 410994819f62b0bd105ca398c335d76993fd694b8e7f56c761b94fc1e2f6e90f2010f2f2a88febd71ac0c5643fc0e923c60151fbf9411e8a553b5917d6bcd8db SHA512 4b0a5e79f90ee8122fa8d0a7224fee6472b1762a0dda680ea1c0e8d4069760be9b6472e052b1b166a389c0e779816b98715386dbc62a3574e7ad851b2567a070
+DIST gentoo-bashcomp-20230313.tar.bz2 21536 BLAKE2B 5dc47aecf68fc19c177026582d98b441d09a15bf0f9e618533c62a37b7986ab6d619f2873b58697f484830bbe88e7697755bb7ee14fb8c55be12e7296e1acfec SHA512 482bf1444e76da544bfbab727f9016abcc82ed4283e31e7ad1e1d302cfe67edfc55cdc37871ae53c09e4e3ce5a5e20dd5f8994ec60e1698076bc81659a2fa3b0
EBUILD gentoo-bashcomp-20190211-r1.ebuild 745 BLAKE2B 27670d155e17573b710018641de88818f340fa9a59e3e095cfc3f8eb6c89dabda89d91d32d0c910ae8a2cf86e37691c56b3afe6e3597f25b840da0dce807ef59 SHA512 f5d0e6a73ba692f6202185b1b893535aa7013393a803e638957dcfbc49ad5559f82694272999ff93d159611758b7b69a3d383d6d3bf0afd186b150cc351cb629
+EBUILD gentoo-bashcomp-20230313.ebuild 753 BLAKE2B c0ba5b7d9674830502ea4c80d6c2f639c6d27d75c26f15fecde0786a425b40e2adc91f782bb7a39a0a0c68dfa176ed6f842bde5ef509c3ed089fc94676eda55c SHA512 51aec1c8c70a056c122d28a65fea9ba55cd54f4183550963bd7a8f88d4b2f26c1b35e92e11544f773398d4904d73db788b1892a78e77c4c9d0fdbee4d4f009c1
MISC metadata.xml 266 BLAKE2B 74ac06b4ea12603c8713e69cbff9ce6874266fc48ee5c846f0ac3d50bf577c3edb1e4b6690ec44fc4dd51e55e96dd5c2478831c9f754b04661fe7700d8baf66f SHA512 b996554131284e3556af42d2c5032c5b1635de67d48983096991935e7ee04c32aadc93e48cae5160861e86d64eb6fd4abafc40d9dd8b85ddc032b042a77677cb
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild
new file mode 100644
index 000000000000..eb5aaaeec783
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-bashcomp.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}