summaryrefslogtreecommitdiff
path: root/app-shells/gash/gash-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-shells/gash/gash-0.3.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-shells/gash/gash-0.3.0.ebuild')
-rw-r--r--app-shells/gash/gash-0.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/gash/gash-0.3.0.ebuild b/app-shells/gash/gash-0.3.0.ebuild
new file mode 100644
index 000000000000..e9394761cf3c
--- /dev/null
+++ b/app-shells/gash/gash-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="POSIX-compatible shell written in Guile Scheme"
+HOMEPAGE="https://savannah.nongnu.org/projects/gash/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+RDEPEND=">=dev-scheme/guile-2.0.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}