summaryrefslogtreecommitdiff
path: root/app-shells/fzy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /app-shells/fzy
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'app-shells/fzy')
-rw-r--r--app-shells/fzy/Manifest2
-rw-r--r--app-shells/fzy/files/fzy-0.9-cflags.patch11
-rw-r--r--app-shells/fzy/fzy-0.9-r1.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
index 2b731f109efe..acdebf209d99 100644
--- a/app-shells/fzy/Manifest
+++ b/app-shells/fzy/Manifest
@@ -1,3 +1,5 @@
+AUX fzy-0.9-cflags.patch 299 BLAKE2B 61685e7180741ec77449b5de6fa711b4939faedd94dfcfd84ec86be0ef963b13d5a5308e294f4f22e83682982671a528b64446979fe41e112aeb8c5d143e865e SHA512 f3ea9b90a75f0a013466ef00190dbca451b22015e0a3c3f7e823f61dc2e4ef7d64f90a9685fec311675fb6c5bc788bb7436da2fd89f4f6baade4dfbee8318635
DIST fzy-0.9.tar.gz 42992 BLAKE2B ebc7e73e0387101da65896a4108705048bb72b01261ea86a0abeaee22fe4517ac54351d508bb79419b05a15aa9c93c5d815c34d15353d01c02381e5d342e75b7 SHA512 71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0
+EBUILD fzy-0.9-r1.ebuild 748 BLAKE2B d79ee7668ea80c307dd08ade2ec1f9b37755bc1864c315212cd5c06b69efdb29f1afea6d6426ef76a362e1f815307e80f676ecce675ddff7cd67b8c1baa189d7 SHA512 7280d7d67a97663649cc7efc188e17ba551513c55892dc3e50c130bf35501e15a34e06739a95b25664a900518b686763de795c4e410fdb1b56ad6efd5f1bc11e
EBUILD fzy-0.9.ebuild 737 BLAKE2B 92aa9818d33f9a1a03e2adff05ae44c815e500e2d35fc19af7d746f08637d990bd96a317411c6953adeb9bb269f185b6d76ffdfe0dcabcab2864ec3dc7b4e15f SHA512 6e130c3b7bc2f90fafd4f73add389bbb657967a793f95ac9348ae3ab461d13ce8f21c64316d2714d2a0dc12d9853849d39885103c1b46e816446484e4f30a7b3
MISC metadata.xml 1003 BLAKE2B 9ac27e76694a7e5213431b0cda2b7824d0c30da29e9137537250c3bc53537216104b4c3fa602be4e1b9d68286f1ddb8b411510250a320a51f63dc2f0007e2399 SHA512 5970a188a0c270dda4c6dc13520daf7ebe4fbcb48cf19fd1c3ad5f708c480cb9ba26ccf181b8534246d556a23bfb5252dd48cd91b047164cea302fb593c91563
diff --git a/app-shells/fzy/files/fzy-0.9-cflags.patch b/app-shells/fzy/files/fzy-0.9-cflags.patch
new file mode 100644
index 000000000000..328abc9c6fe7
--- /dev/null
+++ b/app-shells/fzy/files/fzy-0.9-cflags.patch
@@ -0,0 +1,11 @@
+--- fzy-0.9/Makefile
++++ fzy-0.9/Makefile
+@@ -1,7 +1,7 @@
+ VERSION=0.9
+
+ CPPFLAGS=-DVERSION=\"${VERSION}\" -D_GNU_SOURCE
+-CFLAGS+=-Wall -Wextra -g -std=c99 -O3 -pedantic -Ideps
++CFLAGS+=-Wall -Wextra -std=c99 -pedantic -Ideps
+ PREFIX?=/usr/local
+ MANDIR?=$(PREFIX)/share/man
+ BINDIR?=$(PREFIX)/bin
diff --git a/app-shells/fzy/fzy-0.9-r1.ebuild b/app-shells/fzy/fzy-0.9-r1.ebuild
new file mode 100644
index 000000000000..3db8979e1bd9
--- /dev/null
+++ b/app-shells/fzy/fzy-0.9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+
+src_prepare() {
+ default
+ restore_config config.h
+
+ tc-export CC
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}