summaryrefslogtreecommitdiff
path: root/app-shells/fzy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /app-shells/fzy
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'app-shells/fzy')
-rw-r--r--app-shells/fzy/Manifest3
-rw-r--r--app-shells/fzy/fzy-0.9.ebuild33
-rw-r--r--app-shells/fzy/metadata.xml27
3 files changed, 63 insertions, 0 deletions
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
new file mode 100644
index 000000000000..2b731f109efe
--- /dev/null
+++ b/app-shells/fzy/Manifest
@@ -0,0 +1,3 @@
+DIST fzy-0.9.tar.gz 42992 BLAKE2B ebc7e73e0387101da65896a4108705048bb72b01261ea86a0abeaee22fe4517ac54351d508bb79419b05a15aa9c93c5d815c34d15353d01c02381e5d342e75b7 SHA512 71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0
+EBUILD fzy-0.9.ebuild 737 BLAKE2B 92aa9818d33f9a1a03e2adff05ae44c815e500e2d35fc19af7d746f08637d990bd96a317411c6953adeb9bb269f185b6d76ffdfe0dcabcab2864ec3dc7b4e15f SHA512 6e130c3b7bc2f90fafd4f73add389bbb657967a793f95ac9348ae3ab461d13ce8f21c64316d2714d2a0dc12d9853849d39885103c1b46e816446484e4f30a7b3
+MISC metadata.xml 1003 BLAKE2B 9ac27e76694a7e5213431b0cda2b7824d0c30da29e9137537250c3bc53537216104b4c3fa602be4e1b9d68286f1ddb8b411510250a320a51f63dc2f0007e2399 SHA512 5970a188a0c270dda4c6dc13520daf7ebe4fbcb48cf19fd1c3ad5f708c480cb9ba26ccf181b8534246d556a23bfb5252dd48cd91b047164cea302fb593c91563
diff --git a/app-shells/fzy/fzy-0.9.ebuild b/app-shells/fzy/fzy-0.9.ebuild
new file mode 100644
index 000000000000..28bbf0fbf06b
--- /dev/null
+++ b/app-shells/fzy/fzy-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ eapply_user
+ sed -i -e '/^CFLAGS/s/ -O3//' Makefile || die "sed failed"
+ restore_config config.h
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}
diff --git a/app-shells/fzy/metadata.xml b/app-shells/fzy/metadata.xml
new file mode 100644
index 000000000000..e97ca2a7fe00
--- /dev/null
+++ b/app-shells/fzy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ya@sysdump.net</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fuzzy text selector (interactive grep) for console.
+ It can be used to filter any list:
+ files, command history, processes, hostnames, bookmarks, git commits, etc.
+ It's designed to be used both as an editor plugin and on the command line.
+ Rather than clearing the screen, fzy displays its interface directly below
+ the current cursor position, scrolling the screen if necessary.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jhawthorn/fzy</remote-id>
+ </upstream>
+</pkgmetadata>